Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently using Windows XP SP3 32 bit, using C2D E6320 with 2GB RAM. When I am playing Starcraft 2, I encounter an error where it says my system is running low on page pool memory. Starcraft graphic settings suggested a high settings for me. I do not think it has to do with my GC but with my RAM.

I then made a search to try to rectify the problem. Apparently, it's something to do with my virtual memory. I then proceed to try to the suggested solution which is to temper the registry and limit the page pool memory to 384MB. However, having done so, I still could not achieved it.

I've seen screenshot settings of windows XP with 2GB having 384MB of page pool memory. My default settings puts it at 195MB whereas when I try to increase the pool limit, it can only go to a max of 229MB. I tried increasing my RAM capacity to 3GB but the pool limit still remains.

I like to know how to increase my page pool memory. I've tried searching for solution but to no avail other than the one that I've mentioned above (which didn't solve my problem completely).

share|improve this question

3 Answers 3

XP is limited to a paged pool of 400 MB - this limit cannot be exceeded. However, because of limitations of the XP memory management, the paged pool may be limited to 100 or 200 MB on your system (depending on your chipset, BIOS, graphics card VRAM, drivers, boot.ini, etc.). XP 64-bit is much better.

Vista and W7 32-bit are limited to a pool of 2 GB, and 64-bit are essentially unlimited.

This Microsoft article might help: Server is unable to allocate memory from the system paged pool.

It lists two registry key situated at
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management.

PoolUsageMaximum (REG_DWORD) : value at which the Memory Manager starts trimming the pool. Default is 80, but you can set it to 60 or even 40.

PagedPoolSize (REG_DWORD) : setting the value to 0xFFFFFFFF allocates the maximum paged pool.

share|improve this answer

This Blizzard support page covers this issue:
http://eu.blizzard.com/support/article.xml?locale=de_DE&articleId=45609

Basically, shut down your antivirus application and anything else you can. Make sure your display drivers are up to date.

share|improve this answer

A really in-depth guide to various memory types in Windows can be found at Pushing the Limits of Windows: Paged and Nonpaged Pool

Basically it looks that prior to Vista and Windows 7 the page pool limit is set start-up and is related how much memory is available in the system and whether you have 32-bit of 64-bit Windows.

I would expect to get the largest available paged pool you need to get the full 4GB of physical memory WinXP can handle.

On 32-bit Windows XP, the limit is calculated based on how much address space is assigned other resources, most notably system PTEs, with an upper limit of 491MB.

32-bit Vista and onwards:

Since 32-bit Windows Vista and later have dynamic kernel address space, they simply set the limit to 2GB. Paged pool will therefore run out either when the system address space is full or the system commit limit is reached.

64-bit Windows XP:

64-bit Windows XP and Windows Server 2003 set their maximums to four times the nonpaged pool limit or 128GB, whichever is smaller.

Which is in turn dependant on the Nonpaged pool:

64-bit Windows XP and Windows Server 2003 set the maximum nonpaged pool to a little over 400K per MB of RAM or 128GB, whichever is smaller.

And as a last point Vista and Windows 7 simply set the paged pool limit to 128GB (in practise it is only limited by how much the system can commit to the page file)

Finally, 64-bit versions of Windows Vista, Windows Server 2008, Windows 7 and Windows Server 2008 R2 simply set the maximum to 128GB, allowing paged pool’s limit to track the system commit limit.

The one way to truly get rid of the limit is to upgrade your operating system, preferably to a 64-bit version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.