Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Windows XP on my macbook w/ boot camp, like I've done before, but I'm getting a 'Disk error' now whenever I try. I've reformatted the machine with OSX 10.5 on a Mac OS Extended (Journaled).

Here's how far I get: - Use boot camp to partition the drive, it then says to insert the cd, and I can press a button after the partitioning is done to restart and install. - after the restart occurs, the windows setup begins, and I install, there is a C drive (fat) and an option to install on this drive and leave it as is (or I can format as NTFS at this step), so I install on C as it is - after the install is done the computer restarts, immediately after the restart though I get a 'Disk error' message is DOS at the top left of my screen, directly after 'Press any key to boot from CD.."

After first getting this error I tried installing windows again using a quick NTFS format, but got the same error w/ an addtional message about some missing dll afterwards, so I tried booting into OSX after this and restored the drive w/ boot camp, then tried again, but got the same error once again..

An idea what I can do to resolve this issue?

Update

Here's the error that I get when I format the drive as NTFS, instead of the 'Disk error':

Windows could not start because the following file is missing or corrupt: \system32\hal.dll Please re-install a copy of the above file.

share|improve this question
up vote 0 down vote accepted

After reading this article I realized my mistake, I either deleted the bootcamp partition and created a new one, or used the "Leave the current file system intact (no changes)" option, both of which I should not do. I had to install to the BOOTCAMP partition, do not delete it, then I was asked about formatting the partition, which I choose NTFS for, and then that worked!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .