Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I enter the page: http://connect.facebook.net/en_US/all.js

I am getting Error 330 (net::ERR_CONTENT_DECODING_FAILED). But when I try to use FF, it works.

BTW, the facebook social widgets (which load this file) is not working on Chrome. I have the latest version.

What is wrong ?

Thank you.

share|improve this question

closed as too localized by random Apr 30 '13 at 16:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
BTW, it works on Chromes from other PCs. And I'm using Win7 Ultimate 64 bits. –  Gabriel Bianconi Aug 6 '10 at 20:35
add comment

6 Answers

This can happen when an HTTP request's headers claim that the content is gzip encoded, but it isn't. This happened to me just now on Wordpress where I had WP Super Cache's gzip compression enabled. Normally it worked fine, but when I dumped some content out before the page was properly generated, it screwed up the compression.

Resolution if you're the web developer: turn off gzip encoding or make sure the content is in fact encoded.

share|improve this answer
2  
+1 for this as an explanation- I've run into this problem w/ Amazon cloudfront + s3 with Django 1.4 when AWS_IS_GZIPPED was set to True in application configuration. –  Jay Taylor Sep 17 '12 at 20:20
    
I have oscommerce setup. Turning off gzip solved the issue. Was wondering how ideally I could enable real gzip encoding for the website instead. Must be configurable from htaccess or PHP –  Saurabh Kumar Jan 12 '13 at 3:46
add comment

Using codeigniter, go to /config/config.php and set

$config['compress_output'] = FALSE;

And this worked for me, but the real solution should be inside apache configurations

share|improve this answer
    
where is /config? –  Simon Sheehan Feb 22 '12 at 22:18
    
I don't think your answer relates at all to the question. –  Oliver Salzburg Feb 22 '12 at 23:30
    
it worked for me, this is the issue I got. –  fengd Apr 14 '12 at 7:41
add comment

I reinstalled Chrome and it fixed the problem.

share|improve this answer
add comment

Reason also could be your antivirus web shield. In my case I had issues with a lot of css files, so I set exclusion rule for css files. Try turning the shield off for a minute, reload the page you have problems with (use full reload, Ctrl+F5). If it works, try to exclude js files (you can also do it for css files before you even get such problems with them) from your web shield

share|improve this answer
add comment

I had this affecting all web pages (not even Google would load).

Closing Chrome and starting it again solved it for me so far. If it turns out to be a recurring problem, I’ll try re-installing Chrome.

share|improve this answer
add comment

I had a client using an older theme that used php and declared: ob_start("ob_gzhandler");

Thing is Apache was config'd the server gzip'd content so the content was compressed "twice" this caused the same error in chrome for me.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.