Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a cross-over ethernet cable to connect a Desktop Windows 7 box, and a laptop running on SUSE 11.2. I want Windows to connect to the internet via the laptop's wireless interface.

Windows 7 (eth only)
(eth) IP:

eth0 IP:
wlan0 IP:

Wireless Router

# SUSE ROUTES   U     0      0        0 eth0   U     2      0        0 wlan0       U     0      0        0 lo         UG    0      0        0 wlan0

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
    276         On-link    306         On-link    306         On-link    306         On-link    276         On-link    276         On-link    276         On-link    306         On-link    276         On-link    306         On-link    276

Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
share|improve this question
Any firewall running? – bryan Aug 7 '10 at 2:49
can you provide the routing table of windows computer too? – bryan Aug 7 '10 at 2:51
All FW disabled, on all machines. – Felipe Alvarez Aug 7 '10 at 3:14
can you run cat /proc/sys/net/ipv4/ip_forward and post the result? – bryan Aug 7 '10 at 3:56
cat /proc/sys/net/ipv4/ip_forward returns '1' – Felipe Alvarez Aug 7 '10 at 5:37

1 Answer 1

up vote 0 down vote accepted

I had to add a static route to my wireless router BACK to the network via (laptop). Now windows can browse web via lappy!


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.