Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to hibernate Ubuntu (which fails, but thats another issue) and resumed my system.

After this, the sound doesn't get played.

What command can/should I run to restart the ubuntu sound system.

share|improve this question
up vote 7 down vote accepted

If Ubuntu is still using Alsa for its sound engine (I'm not sure as its been awhile since I've used it), you can restart by typing sudo /etc/init.d/alsa-utils restart into the terminal.

Since it doesn't seem to be working, you might need to make sure that nothing is trying to use it. (example shamelessly stolen from the Ubuntu forums)

name@comp:~$ lsof | grep pcm
sh 5079 name 70u CHR 116,6 13639 /dev/snd/pcmC0D0p

name@comp:~$ kill -9 5079
share|improve this answer
You may also have to restart pulse-audio. – Dana the Sane Aug 2 '09 at 19:04
Nice try. Good answer. But in my case, doesn't solve the problem. Yes, to my best knowledge, I use ALSA itself. – Lakshman Prasad Aug 2 '09 at 19:04
Any specific order to follow. Restarted both. No luck. I am confident, by restarting my system, sound will work. But I dont want to. – Lakshman Prasad Aug 2 '09 at 19:06
Seems like I will have to kill firefox, chrome, and gnome-panel. As good as restarting the system :| . Anyway, thanks! – Lakshman Prasad Aug 2 '09 at 19:11

Ubuntu swichted to pulseaudio some time ago, so it would be sudo /etc/init.d/pulseaudio restart

EDIT: In case that doesn't cut it, you could also rmmod and modprobe the kernel modules used for sound. Which those are probably depends on your sound card. lsmod might give you a clue...

share|improve this answer

$ alsa Usage: /sbin/alsa {unload|reload|force-unload|force-reload|suspend|resume}

$ sudo alsa reload

share|improve this answer
Can you expand your answer a little to explain it? Thanks. – fixer1234 Apr 30 at 19:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .