Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Linksys WRT54GS and have two machines on my network connecting wirelessly. DHCP is enabled, and is granting IP addresses in the .100-120 range. The one machine is a laptop running Ubuntu 10.04 and it is working via DHCP, IP address .103.

The second machine, OS X 10.4, I set to a static IP in order to allow port forwarding from the router, as per these instructions: It's grabbing an IP address outside of the DHCP range; .13.

Since I did so, the Mac can see the local network, and I can access the router config from it, but all traffic outside of my LAN is blocked for that machine. I see no settings indicating any sort of filter or rules that would block web access.

Where did I go wrong?

share|improve this question
up vote 1 down vote accepted

When manually configuring the 10.4 machine, did you enter the subnet mask and the router's address correctly?

When testing off-network connectivity, did you try connecting to things by IP address or just by name? Because maybe you forgot to enter a valid DNS server address on your 10.4 client, and since it's not getting that information via DHCP anymore, it doesn't know who to ask when it needs to look up the IP address for a given hostname.

share|improve this answer
You know what, I use OpenDNS - I'll double check that I've got the right settings. I'll bet that's it. Gateway and Subnet mask settings are good. I'm at a local cafe atm - only way I can check these responses! I'll try it and get back to you. – hewhocutsdown Aug 7 '10 at 15:59
It was the DNS! thank you – hewhocutsdown Aug 7 '10 at 19:05

Are you trying to use the "DHCP with Manual IP" setup available in OS X's Network system preferences? I personally have never gotten that to work properly. Make sure you're configuring TCP/IP "Manually" and copying all of the addresses (Including DNS) from what would be distributed by DHCP except for the IP address.

Something else I would recommend, not as a fix but as an advanced alternative, would be to set up your router to do some static DHCP: distribute a predetermined IP address to the 10.4 machine based on the MAC address of its ethernet interface. You probably can't do this with the stock firmware on that router, but that router is well known in the community to be a good candidate for alternative firmware such as DD-WRT. I personally have had great success with Tomato, which is very lightweight and easy to use, while drastically expanding on the limited feature set of Linksys stock firmware.

share|improve this answer
"DHCP with manual address" requires your DHCP server to support the DHCP Inform (information request) message type, which allows a client to request information about what configuration settings to use without actually requesting an IP address lease. Most embedded DHCP servers don't support Inform, so most people can't use this on their home network. – Spiff Aug 7 '10 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .