Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 4Gb USB pen drive that I'm trying to format with FAT32.

When I run fdisk, it gives me this message:

The number of cylinders for this disk is set to 64349. There is nothing wrong with that, but this is larger than 1024, and could in certain setups cause problems with: 1) software that runs at boot time (e.g., old versions of LILO) 2) booting and partitioning software from other OSs (e.g., DOS FDISK, OS/2 FDISK)

I've tried deleting the partition table, creating new partitions, etc, but they never work. Sometimes I can write to the drive the first time I use it after formatting it, but then it becomes read-only in both Windows and Linux.

I've tried this on multiple computers.

Am I doing something wrong, or is the drive reporting an incorrect number of cylinders? Is the drive itself likely to be corrupted, and is there anyway to fix this under Windows Vista or Linux?

Thanks

share|improve this question
add comment

1 Answer

It seems I needed to set the type to W95 FAT32 (LBA) (ID 'C'). I'd been using W95 FAT32. I think it's OK now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.