Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

2 comps. Both win xp sp2.

CompA, CompB

CompB has a shared folder, C:\blah

CompA can access it \compB\blah

CompA can open files in \compB\blah CompA can see folders in \compB\blah, and it can open them, but I have this issue..

One folder \blah\a Is fine. I can open any files in it from CompA.

Another folder, \blah\b I can go into it but cannot open files. e.g. open a text file in notepad, "Access is denied"

Another folder, I cannot open it. It says "You might not have permission to use this network resource" (this was a folder made by copy/pasting it from elsewhere)

I would like to be able to view and open all these files/folders. i.e. I would like the latter 2 folders to be as good as the first one! I would like to know what setting is missing..

share|improve this question
    
XP sp2 reached end of life last month -- no more new security patches. You really need to update these to sp3. –  Joel Coehoorn Aug 8 '10 at 16:30
add comment

1 Answer

up vote 1 down vote accepted

The accounts used for logon on CompA and CompB, AccA and AccB, should be defined on both computers with the same password.

The appropriate access permissions must be granted to the shares to allow AccA and AccB the appropriate access (right-click on directory, Properties, Security).

The shared directories should also have the right permissions (right-click on directory, Properties, Sharing, Share this folder, Permissions, give Everyone the right permissions).

share|improve this answer
    
Adding Everyone sorted out the folder i couldn't see. And, I see that in the folder where I can see but whose files I can't see, I see they don't have "Everyone" set. So no doubt setting that would prob fix it. How do I add "everyone" for multiple files, or all the files in a folder? –  barlop Aug 8 '10 at 18:12
1  
@barlop: Add account to the folder, then click Advanced, select new account, click Edit, then check "Replace ... on all descendants". This is Microsoft's "rat in a maze" intelligence test. –  harrymc Aug 8 '10 at 18:41
    
Thanks, I see it. those 2 checkboxes. One of them being "Replace...apply to all child objects" That worked! I don't know about adding account .. but security tab..advanced..then that checkbox. worked. –  barlop Aug 8 '10 at 19:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.