Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Windows Vista Home Premium Service Pack 2. Dot Net Framework 4.0 is installed in my computer. But when I am trying to install Microsoft Small Basic, It is showing an error "This application requires .NET Framework 3.5 SP1" and installer exited. How can I fix this problem?

share|improve this question
up vote 2 down vote accepted

I suppose you could try installing Framework 3.5 and its SP1.

I would expect programs to be happy with a later version but maybe Small Basic requires something that is only in that version or somebody forgot to add the "or later" bit when specifying that Small Basic needed version 3.5 or later. Anyway, at least the installer is giving you a clue about why it is failing...

share|improve this answer
1  
Your answer is correct, but versions of .net don't work like this. 4.0 does not necessarily include 3.5 or 3.0 or 2.0 or 1.1! So every version needs to be separately installed, although 3.0 and 3.5 depend on 2.0 – AndrejaKo Aug 8 '10 at 19:56
    
Quite. I have trouble with all the different versions. It seems that the versions work as one would expect versions to work up to version 2 (apart from where they don't), and version 3.5 gets round it by installing versions 2.0 and 3.0 alongside itself. I have no idea what version 4 does, maybe from the problem above it has given up in disgust. I was trying to avoind an answer which just said "Well, install what it tells you then!" – Neal Aug 8 '10 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .