Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Previously my bash script was pointing to /path1 but I moved it to under /path2, now if I do "type myscript" it's still pointing to /path1, how do I solve this?

share|improve this question
    

1 Answer 1

up vote 3 down vote accepted

I believe it's this:

hash -r
share|improve this answer
    
I closed my bash session and started a new one and that solved the problem too. I thought I tried that before, but I could be wrong. –  grokus Aug 9 '10 at 14:25
    
@grokus It's nice not to have to start a new shell - especially if you're logged in over ssh - but a new shell should do it. –  Telemachus Aug 9 '10 at 14:27
    
@Telemachus, thanks. Next time I run into this, I will try "hash -r". –  grokus Aug 9 '10 at 14:34
    
@Telemachus, can you vote my question up? I have more than 100 reputations on all other SE sites but not this one. It sucks to have 1 point, I can't even vote up anything. :( –  grokus Aug 9 '10 at 14:36
1  
@grokus I'll vote it up, but you must promise to put the question back. Otherwise, this thread is getting awfully silly. (I currently have an answer in search of a question.) Also, can't you accept answers no matter what your point level is? (That gets you points as well.) –  Telemachus Aug 9 '10 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.