Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My system died several months ago. I had enough warning to back up the hard drive, though. Now I'm digging through the backup trying to pull out a few files. One of them is an old OpenOffice Impress presentation. I can open it and it mostly works, except for one slide that used to have a video clip on it. Now it's just a big gray box with a question mark.

I can't find the linked video clip in the backup. Problem is, I can't find its location and filename from OpenOffice either. I did what any experienced Windows user would do, right-clicked on it and went to Properties to get the linked path... but there's no Properties in the context menu, and none of the stuff in the context menu actually helps. The information has to be there somewhere so OO knows where to find it. How do I access it? It's gotta be something simple that I'm just overlooking, right?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

The impress file is a zip file with a different extension. Rename the .odp file to .zip, use a zip utility to open the content.xml file contained therein and search the content file for video file extensions. In a test I did, I found the video file link in a <draw:plugin xlink:href="path/name.avi" ....</draw> xml element.

share|improve this answer
    
OK, that worked. Though it really shouldn't be that... manual. There should be some way to get the information from within Impress. I find myself rather "unimpressed." –  Mason Wheeler Aug 10 '10 at 17:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.