Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a company-issued PC (Dell Latitude D630 running Windows XP SP3), using PowerPoint 2003 (11.8324.8324) SP3. If I embed a video of any supported type (WMV, AVI, MPEG) using a Media Player OLE object, the video does not visibly play when the presentation is in Slide Show mode. It also does not play if I right-click and select "Play". Sometimes, but not every time, you can hear the audio from the file, but the video never plays.

This can be reproduced on every PC in my department, all Dell laptops of various vintages running the same version of Windows and Office.

Embedding itself works. For instance, I can embed a SWF file as a Shockwave Flash object and it works perfectly.

We can hyperlink to the same videos and they play fine, but it's clumsier and not as elegant or useful.

Any suggestions on how to proceed would be much appreciated.

share|improve this question
Did any of the solutions work? – Ryan Aug 18 '10 at 18:56
Nope. As mentioned in the comments to the questions, all suggestions were either irrelevant, or things I had already tried. – CarlF Aug 19 '10 at 4:26

This issue may occur if any one of the following conditions is true:

  • The hardware acceleration setting of the display device is too high.
  • The required codec is missing or damaged.
  • Conflicting third-party video software is installed on the computer.
  • The video acceleration of Windows Media Player is too high.

The solution to all of these issues can be found here.

share|improve this answer
Coming back to this old question: it happens with acceleration set to be zero in both WMP and Windows, with any codec, and the only video software on the box is WMP. It's some weirdness in the company setup. – CarlF Sep 15 '13 at 4:34

I have had the exact same problem before, an I have found the solution to be to transcode the video into wmv. The problem is that you are probably missing a required codec. Just transcode the video into wmv and you should be OK. What format are you using?

share|improve this answer
As mentioned in the question, I have tried AVI, WMV, and MPEG video. All fail. I can play FLV video using a Flash (SWF) player (as opposed to embedding Windows Media Player), but that's too complex a setup for most of our staff. – CarlF Aug 13 '10 at 16:29
Does the video use an MPEG 1 or 2 codec? I.e. when you got the video, did it use an MPEG codec to encode the wma? – Pilotbaxter007 Aug 13 '10 at 16:59
I've tried MPEG 1, MPEG 2, MPEG 4 ASP (DiVX), WMV9 and WMA9, and even MJPEG. Nothing. – CarlF Aug 13 '10 at 21:32

I have had this problem as well. I think you should try MPEG-1 (not MPEG-2) video if you haven't yet, that worked for me and should probably always work.

share|improve this answer
I've tried both MPEG 1 and 2. Nothing. The embedded video player turns black and ... that's it. – CarlF Aug 13 '10 at 21:32
  1. I had the same problem. Try this:
  2. Insert | Object | Browse for file - your video clip
  3. To play when the slide is clicked, do this: a. Slide Show | Custom Automation | Add Effect | Object Actions | Activate Contents
  4. If you don't want the warning coming up when you play, then do this: Tools | Options | Security | Macro Security | Low

This process inserts the video clip into the presentation - you then only need the ppt, you don't need to have the file with the video clip also

share|improve this answer
thanks, but I had already tried that. (This question is approaching a year old, I've tried lots of things.) When activated the embedded object opens a separate Windows Media Player window which then ... doesn't play anything. – CarlF Jun 16 '11 at 15:54

Try this:

  1. insert the movie from file
  2. on the actual slide in edit mode right click mouse while pointer is on black box
  3. select edit movie object from the menu that should have come up
  4. Move mouse pointer to box - zoom to full screen and click left mouse button so tick shows

I was having similar problems and this worked for me.

share|improve this answer
Not for me. Freezes PowerPoint entirely. Thanks for trying on this very old question, though. My company will be upgrading me to PP 2010 soon, and in any case we're largely abandoning PP in favor of SMART Notebook anyway. – CarlF Apr 25 '13 at 15:31

I have Powerpoint 2010 and under the File button is a choice to Optimize Media Compatibility and it worked. Why it would not work on my own computer without first making it “compatible” is a mystery, but this step worked for me.

share|improve this answer

in PPT 2013, go into 'File' - 'Options' - 'Advanced' and tick 'Disable Slide Show Hardware Graphics Acceleration'

share|improve this answer
Already suggested back in 2010, and already shown not to be the problem. – CarlF Feb 10 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .