Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I bought a VIA VT6421A based SATA card for an 845 chipset based motherboard. The card is working – I can access the SATA HDD from Windows/Linux.

The problem is I can't directly boot from the SATA card. My motherboard is Award BIOS 6 based. I tried first boot as SCSI, it did not work.

There is no RAID BIOS screen appearing from the card. On searching I found that I could add the VT6421A BIOS to the system BIOS as a PCI Add-on BIOS. I did it using CBROM6 , successfully added the VT6421A BIOS to the existing BIOS.

But now on booting, instead of the RAID BIOS, the system BIOS showed a warning, something like "cannot load add-on ROM for vendor id xxxx device id xxx".

What's wrong? The card is VT6421A-based, so I added a VT6421A BIOS I got from the VIA website.

share|improve this question

migrated from Aug 3 '09 at 2:38

This question came from our site for system and network administrators.

What is the model and brand of motherboard you are using? – Jack B Nimble Jun 15 '09 at 7:01
I assume you are using "bootable add-in cards" in the boot order and not looking for the actual hard disk? – flashkube Jun 15 '09 at 19:44
Iam using a local(indian) 845 chipset based notherboard. Ther is no bootable addon card option in bios – Priyan R Jun 16 '09 at 4:10

I've just solved this problem (ASUS P5LD2-X and Pluscom S4PB-VT6421A).

The problem is the card: there isn't a BIOS for bootstrapping on it, so the only possible solution (as I read on another forum) is to add the BIOS of the card on the BIOS of the motherboard. So, exactly as reported here. I downloaded last BIOS for MB, the wonderful MMtool (v.3.26, used for patching BIOS) and I cancelled the logo from the MB to create space enough to put the ROM I downloaded.

Obviously check if vendor ID and device ID of BIOS SATA card are the same of your card (it fits with mine, vendor ID 1106 and device ID 3249).

The system now works perfectly and on post phase, pressing TAB I have the possibility to create a RAID volume.

share|improve this answer

In my experience an add-on Mass Storage card should always show its BIOS 'boot text' regardless of Mainboard BIOS settings (assuming the addon card isn't really an integrated motherboard component).

Have you tried the card in another machine? Tried it in another PCI slot?

share|improve this answer
Didn't try it on another motherboard, but i don't think its the problem of motherboard, I added the via vt6421a boot rom to my bios as an PCI addon rom, but its not working, bios shows some cannot load the addon rom – Priyan R Jun 22 '09 at 10:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .