Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to compare two folders, each having about 5-6 thousands files and folders. Among these probably 0.1% would be actually different but Win Merge first shows all files saying "text files are different" and when I open these files one by one it opens a dialog saying contents in both files are same. It is nearly impossible for me to find files actually having different text, in this way.
First, I tried to set options but no cuccess.
Then, I thought this initial difference may be due to different time stamps. So I made all file time stamps (create, last modified and last accessed ) exactly same but result is still same.
Am I missing something? or is there any way to to filter the list so that I may see only the files with some difference? or any other idea?

share|improve this question

migrated from stackoverflow.com Aug 10 '10 at 15:25

This question came from our site for professional and enthusiast programmers.

    
Are you ignoring white space when viewing each file? –  Oded Aug 9 '10 at 19:25
    
YES, I am ignoring both white spaces and different line feeds –  SJP Aug 10 '10 at 1:50
    
Try Beyond Compare. –  Greg Hewgill Aug 10 '10 at 9:45

4 Answers 4

Try setting the Compare option "Ignore carriage return differences".

Differences in line endings (CRLF/CR/LF) are the usual suspect when one mode of comparison (binary) reports differences but another mode (text) claims that the files are the same.

share|improve this answer
    
Its already like this. –  SJP Aug 9 '10 at 22:03
    
You are right @brian, there is really a line feed difference in most of the files that winmerge is not ignoring in first pass. –  SJP Aug 10 '10 at 2:46

Try with the software called 'Beyond Compare'.

share|improve this answer
    
its not free... –  QuiteNothing Aug 20 '13 at 22:58

You might want to try ECMerge or Araxis as well. They both have appropriate settings to ignore spaces / CRLF.

share|improve this answer

I would have thought that WinMerge with the following settings would work:

image

If it doesn't, I would ask the question in their forums.
I believe this is worth the effort, as WinMerge is my best file-compare product.

share|improve this answer
    
Thanks. Whitespaces were headache –  QuiteNothing Aug 20 '13 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.