Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Outlook Express on Windows XP (SP3). Recently I lost the ability to relay mail directly through my e-mail host via SMTP-AUTH, so I switched to using my ISP's relay. That required me changing the SMTP settings of course, and they also require SMTP-AUTH. For some reason, Outlook Express is putting the authentication name from the SMTP-AUTH into the header as my e-mail address (which is completely wrong!). The account e-mail address is set properly, but Outlook Express seemingly ignores it. I went ahead and also set the reply-to address, and that gets set properly in the header (but the "From" is still wrong!).

Example of what someone sees in the header when receiving e-mail from me:

From: Brian Knoblauch <smtprelayaccount@myisp.com>
Reply-to: Brian Knoblauch <brian@myemail.com>

Any ideas on how to force Outlook Express to use the mail address for the uh, mail address? :-)

share|improve this question
2  
Perhaps it's not Outlook Express that's putting the wrong e-mail in the From line. Maybe your ISP's relay is putting it there? Or perhaps an e-mail scanning program on your computer is changing the From address? Try sending a test e-mail in Outlook Express, then look in the Sent Items folder to see what it looks like there. (To see the exact headers, right click on an e-mail in the list, choose Properties, then click on the Details tab.) –  Bavi_H Aug 11 '10 at 0:44
    
It's definitely Outlook Express. My Vista machine with Microsoft Mail is setup the same way, but the header information comes through set correctly. There's no e-mail scanning software installed. –  Brian Knoblauch Aug 11 '10 at 12:07
    
1. Do the headers in the Outlook Express Sent Items folder show the correct or incorrect From address? 2. Are you using the same From address or different From addresses in Outlook Express and Vista Windows Mail? 3. Who is your ISP? (You may have to do something on your ISP's mail website to allow a new From address. If you have a different From address already working in Vista Windows Mail, someone else may preformed that step or you may have forgotten about doing that step in the past.) –  Bavi_H Aug 12 '10 at 2:28
    
1. They show incorrect. 2. Both are setup the same way. 3. My ISP uses Google as their relay. –  Brian Knoblauch Aug 12 '10 at 15:44
    
Hm. I'm running out of ideas. The last thing I can think of is to try removing the account and re-creating it again from scratch. (The initial symptoms you described suggested something besides Outlook Express was changing the From address, but the further details don't paint as clear a suspect as I had hoped.) –  Bavi_H Aug 13 '10 at 0:53
show 2 more comments

1 Answer

If you are 100% sure it is set correctly in Outlook Express (The first page when you double click on the account settings), then I think that this is being intercepted and changed by your ISP and I do not think there is anything you can do to stop it.

The only thing that may help is looking for / using an alternative port if your email provider supports it, or going via a proxy.

share|improve this answer
    
That was my original thought too, but it doesn't happen from my Vista box (with Microsoft Mail) that's setup the same way! –  Brian Knoblauch Aug 11 '10 at 12:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.