Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some dialogs are broken on my system. This includes:
- some file selection dialogs (open and save). Not all of them though. File selection dialogs in some Qt apps (including Qt demo) don't work anymore (when using native dialogs) and file selection dialogs in Visual Studio 2010 do not work anymore. (They do work in visual studio 2008).
- most of the dialogs in Visual Studio 2010, such as add reference, or icon dialog, but not the preferences dialog.

I have tried to find the problem in other applications, with no luck. File dialogs work fine in for example MS Paint and Office 2007. Some applications use "old" file selection dialogs (with Windows 98 style buttons), and those work too. Some software that uses Qt does have working file selection dialogs.

Edit: when the dialog should show up, the main window loses focus (just like it would when a dialog does show up), but then regains focus after about 0.1 second.

Perhaps this is a problem with a specific window flag?

I would appreciate anything that can help me solve this problem, as Visual Studio is virtually unusable now.

OS: Windows 7 Home Premium 64-bit.

share|improve this question
    
Sounds like your .NET install(s) is (are) corrupt. –  user3463 Aug 11 '10 at 20:30
    
I completely removed all my .NET installations and re-installed them. Unfortunately this did not fix the problem. –  Ruud v A Aug 12 '10 at 11:05
    
Have these ever worked for you on this machine? Have you changed anything since then? –  GAThrawn Aug 12 '10 at 12:21
    
Yes, they did work. I suppose I changed something but unfortunately I can't remember what. –  Ruud v A Aug 12 '10 at 12:23
    
If they did work previously, and it's a recent breakage, have you tried a system restore? –  DMA57361 Aug 12 '10 at 12:24

1 Answer 1

up vote 2 down vote accepted

I finally found the problem after a better web search. Thanks very much to this page. The solution was to turn the Tablet PC input service on again. To do so, go to Computer Management -> Services and Applications and turn on Tablet PC Input Service.

share|improve this answer
    
too bad that the link doesn't work anymore :( –  tobsen Mar 4 '11 at 9:49
    
I added more details to the answer, I hope this helps you. –  Ruud v A Mar 4 '11 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.