Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OK, I admit this problem is odd. I'm just trying to understand why Internet Explorer is behaving the way it is. I realise that logic may not apply here :)

  • I have Internet Explorer 6 (Sp1) running on Windows 2000.
  • The Internet Explorer option "Do not store encrypted pages to disk" is checked (enabled).
  • The temporary internet files folder is empty.
  • TEMP and TMP environment variables are set to valid folders.
  • I'm connected to a web server over SSL.
  • The web server is serving a page over SSL with the HTTP cache-control header set to "no-cache, no-store".

I was expecting the "view source" command to be greyed out in this circumstance (as it is on another machine).

But it works. When I "view source", I get an entry in the Temporary Internet Files folder with an "internet address" property of "view-source:https://myserver/...." and the content of the page. I wasn't expecting that.

I can't understand why one machine is different to another in this regard. Obviously there is some environment/setup difference, but I can't track it down.

Anyone have any bright ideas?

share|improve this question

migrated from stackoverflow.com Aug 13 '10 at 14:48

This question came from our site for professional and enthusiast programmers.

    
You may get more help on Super User, since this is not programming related. –  bzlm Aug 13 '10 at 14:27
add comment

1 Answer

I think you're running into a bug with IE 6 and SP 1 taken from here

(7) SSL / Do not save encrypted pages to disk

  • Category: Solution
  • Difficulty: Easy
  • From: Greg
  • Added: September 06, 2005
  • Updated: September 06, 2005
  • Version: Windows - any / IE - any

    If View Source is turned off for https URLs, it may be because of a security setting. >Look in Tools > Internet Options > Advanced tab > Security section, and look for the >option Do not save encrypted pages to disk. When checked off, this option will >intentionally disable View Source.

    And to confuse the issue, according to Microsoft KB article 811102 "Do Not Save >Encrypted Pages to Disk" was not working properly in Internet Explorer 6 SP1, causing it >to leave View Source enabled even when the option was checked. This problem was corrected >in a hotfix. From the KB article: After you install this hotfix, if you load SSL-secured content while you have selected >the Do not save encrypted page to disk option, the Source menu is not available.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.