Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I feel pretty dumb, not sure what I managed to do but I can't log into one database (I have two databases in VM boxes), the website it runs works fine, it works fine with local connections (ie, phpmyadmin) etc...

Database A I'm using MySQL Work Bench to connect to it, which works fine, and there are no problems, but Database B (which is almost the same) keeps giving me "mysql Error occured: Can't connect to MySQL server on ... (ip and port)".

I have added the user I'm attempting to login as to the mysql Privileges, I've even taken my trouble shooting as far as adding the user to have global access from any connection and no password (don't worry, the machine is internal only and nobody even knows about it).

What could cause this sort of thing? I'm not overly advanced in mysql server administration so I'm not even sure where to start searching the web.

share|improve this question
    
Have you tried using the MySQL Command Line Tool to connect? –  Hello71 Aug 13 '10 at 20:43
add comment

1 Answer

up vote 1 down vote accepted

Check your my.cnf and look for the skip_networking parameter. Make sure it's commented out. While in there (assuming that's not the issue) you might also want to look for the bind-address setting and make sure it's not bound to the loopback address or something like that.

share|improve this answer
    
Thanks this worked, all I needed to do was the bind-address. –  Incognito Aug 16 '10 at 13:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.