Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

By child windows, I'm referring to the options(/preferences) dialog, download prompt, XMarks sync. Anything that isn't a browser window, really.

A fresh install of firefox seems to align child windows in the centre of the window. After moving one of these windows, future windows will appear in the same location. Worse yet, if such a window appears whilst the browser is minimised, it starts appearing in the top-left of the screen.

I've also had an issue where the windows have appeared off-screen, whereby I had to use Alt + Space to move the window back to the screen.

How do I tell Firefox to place these windows according to its own rules again?

I plan to make a new profile once 4.0 is stable, but I haven't been able to find an answer otherwise. It's far too time-consuming to setup a new profile just to fix a window-location issue.

share|improve this question
Haver you tried reinstalling Firefox? – Hello71 Aug 14 '10 at 16:53
I've already mentioned that making a new profile fixes the problem, but it's akin to using a sledgehammer as a flyswatter. – Alan Pearce Aug 14 '10 at 21:58
up vote 0 down vote accepted

There are 2 methods to solve this: reset toolbars and controls by safe-mode or manually editing your profile. For a single user case I recommend the former but the latter might be handier if you are administering several computers and try to reset multiple profiles on a Windows network.

Note! Before you do anything, please be aware that these changes reset all toolbar positioning and affects for example tree sort orders etc. It might also affect windows and appearances of your extensions. Saving a screen capture of your old toolbar positioning can help you in restoring your modifications after next Firefox start up.

1. Safe mode method

  1. Close down Firefox completely - all windows and dialogs
  2. Start Firefox in safe mode.
  3. In the Firefox Safe Mode window, select Reset toolbars and controls.
  4. Click Make Changes and Restart.

You are done. Easy and simple.

2. Alternative manual method

  1. Close down Firefox completely - all windows and dialogs
  2. Open the Firefox profile folder
  3. Locate file localstore.rdf and delete the file completely. This file will be recreated next time Firefox launches.

It is also possible to edit localstore.rdf by hand and remove only data regarding window positioning. However this is not recommended due to the complexity of the file. File contents itself is XML serialized RDF data and can easily be viewed or edited in a common plain text editor, but the data is represented as RDF tuples and parts of a same setting are therefore scattered around the file. Correct editing without understanding RDF might be difficult.

share|improve this answer
I went down the manual method, and all seems fine. I plan to make a backup once I've set up my toolbars. – Alan Pearce Aug 15 '10 at 21:39

I've faced a problem when the window of one of my extensions stuck on a full screen render even when Firefox was not full screen. Without the toolbar buttons I couldn't restore the window to a smaller size even. Deleting localstore.rdf didn't help. However after deleting xulstore.json all windows went back to their original position. (Firefox 43.0.4 on Mac OSX 10.11.2)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.