Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

To watch videos, I use Mplayer, which works great. But Ubuntu insists on playing every video file it encounters with "Totem", which I guess is a video player.


I use linux primarily on my laptop, and often on travels, where I have no internet access. All Totem does is launch, and say "should I look for a codec ?", and I have to click no before I can close it.

I know that I can choose "Open with mplayer" for various video formats, but every so often I'll have a file with a different extension, and there comes totem.

I do not seem to be able to remove it from my system, which really infuriates me. I left Windows to avoid programs that you cannot remove. :(

EDIT: If I can't remove it, I'd be happy with a solution to make all video files play with mplayer. I don't want to configure "play with mplayer" for every single file extension there is.

share|improve this question
up vote 9 down vote accepted

It's in the repositories under totem-gstreamer and totem-common, so you should be able to do it with:

sudo apt-get remove totem-gstreamer totem-common

Or by going into your favourite package manager and deselecting it there.

It looks like there's a dummy "totem" package that installs it all nicely, but for some reason in my installation of xubuntu it wasn't installed by default, so a sudo apt-get remove totem would just return "Package totem is not installed, so not removed"

Updated the above to also remove totem-common, which it leaves behind.

share|improve this answer
isn't the totem package a dependency of ubuntu-desktop ? – Manu Aug 3 '09 at 13:20
Ah, good point. I'd assumed Ubuntu wouldn't just dump it on you. Fortunately, ubuntu-desktop is a meta-package, so it shouldn't actually remove anything from your computer, though they don't recommend that you remove it because they use it to "ensure proper upgrades". Try the apt-get command above with a -s, and it'll show you which it's going remove (without actually doing anything). It should only remove the ubuntu-desktop meta-package and not touch any of your existing applications. – Andy Aug 3 '09 at 13:48

Does it work to go to "Preferences"/"Preferred Applications", choose the "Multimedia"-tab and change the default "Multimedia Player"?

share|improve this answer
Thanks, I tried but it shows "rhytmbox" as the "multimedia player". I think that's what is launched when I plug in a mp3 player. – Manu Aug 7 '09 at 15:37

Look into just resetting the file association for any video type files. This works exactly how you would expect it to and this way you can leave totem but choose your player. This article explains it step by step.

Ubuntu File associations

share|improve this answer
Well that's just for one file type. I don't want to have to do it for every single video file extention out there. (+ dvd playback + whatever will come in the future). – Manu Aug 3 '09 at 20:16

If —as implied but I am not that sure that it is indeed so— part of your problem is really that totem does not play your video files, then once when having an internet connection, try to play them and answer Yes to the questions about installing needed software. From then on, it will play your files.

UPDATE: suggested course of action, to be done once; open a console and copy-paste the following:

sudo aptitude install gstreamer0.10-ffmpeg \
  gstreamer0.10-plugins-good gstreamer0.10-plugins-bad \
  gstreamer0.10-plugins-ugly gstreamer0.10-schroedinger

Please let me know if this does not cover all files you have.

share|improve this answer
I thought of that, of course, but won't I have to redo it when I encounter some weird new video file ? – Manu Oct 29 '09 at 18:33
You mean, apart from typical files .wmv, .avi (MPEG4 video), .flv and .mov? The video/audio formats are numbered, where do you find these formats? I'll update the answer. – tzot Oct 30 '09 at 0:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .