Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use Samba to share files between Windows XP and Ubuntu.

I edited the smb.conf and added the workgroup name and netbios name. This is the part that has problems:

[Myshare]
    comment = Myshare
    path = /myshare
    read only = no
    guest ok = yes

When I do sudo samba restart I get the following output:

Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "read_only"
Ignoring unknown parameter "read_only"
Unknown parameter encountered: "guest_ok"
Ignoring unknown parameter "guest_ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"

From my Windows XP machine, I can see the share, but when I try to access it, it says it's not available and I might not have permission to use it. I already changed the permissions of the directory.

When I installed samba, I did sudo apt-get install samba4 I think these problems might be because I'm using a newer version of samba and it doesn't recognize the old syntax from the smb.conf file.

When I try to run smbpasswd it says cli_pipe_validate_current_pdu: RPC fault code DCERPC_FAULT_OP_RNG_ERROR received from host 127.0.0.1! machine 127.0.0.1 rejected the password change: Error was : NT code 0x1c010002.

share|improve this question

3 Answers 3

That's really quite interesting. I'm using a lot of the same configuration options for my Samba34.

That being said, hit up man 5 smb.conf - this will list all the acceptable clauses you can use. Don't forget, also, to make sure each thing is in the correct section. For example, don't have server string = UBUNTU under [Myshare]. By convention, each section should start with a lower case letter. I'd expect Samba to be a little bit more robust, but perhaps it isn't being recognised as a share?

Also, I don't believe read_only and guest_ok are valid entries. The rest of them are valid, so they're most likely not being recognised as applying to any share; they're sitting loose and are hence being ignored.

Start with a light configuration and slowly work your way up. Comment out lines with # and add them back until you find out what's doing it. I don't think [Myshare] is the bit with the issues; I think you've used [global]-only fields under different shares or something like that. The man page should explain where each can be used.

share|improve this answer

WinXP will behave like that if it is able to connect to the share but the top level directory itself doesn't allow reading. It would be good to double-check the permissions are right. You can verify that the right user is being seen by the samba server by running smbstatus while the XP machine is connected to the share. Then verify that the specified Username can read the share's directory.

share|improve this answer

Not that this is the safest way to do it, but you could try something like this. Then, once you have it working, lock it down with tighter security:

security = share 
guest account = publicuser
passdb backend = tdbsam

then

[publicuser]
comment = publicuser Home Dir
path = /home/publicuser
public = yes
writable = yes
write list = +publicuser
browseable = yes
hosts allow = 192.168.10.10

and, in /etc/smbusers

# Unix_name = SMB_name1 SMB_name2 ...
# root = 
publicuser = Administrator smbguest pcguest guest
# nobody = guest pcguest smbguest
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.