Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a Wifi network with my Mac and I could see it on Windows 7 as well as connect to it but when I launch my browser it doesn't work: server not found.

Can Windows 7 work with Mac OS X's Wifi or did I miss something?

I tried the other way round it doesn't work either :(

share|improve this question
Are you just creating an Adhoc Wifi Network or using Mac OS X's Internet Sharing? – Chealion Aug 15 '10 at 19:35
@Chealion I can't see the difference in Sys Prefs. The only thing worth noting are the password schemes allowed, I believe Internet Sharing doesn't allow WPA2. – tobylane Mar 21 '11 at 20:51
@tobylane: Yes, there is a difference in terms of types of passwords - Internet Sharing also turns on NAT and DHCP. – Chealion Apr 5 '11 at 7:14
Chealion go into your network sharing center on your windows machine and right-click the network adapter that you are using. See if there are any specific wi-fi settings you have enabled such as IP/DNS. This must be interfering with the connection since you are connected. Wi-Fi works on every device regardless of the operating system – AlanTuring Oct 1 '12 at 23:06
I think your expectations are the problem. Creating a WiFi network just creates a network. It doesn't provide Internet access to machines on that network. – David Schwartz Jun 20 '14 at 22:15

It should just work fine. Check if the WiFi connections on both Windows and the Mac are granted access to be shared the internet connection with.

share|improve this answer

Yes, i do it every day at home, no specific options to set.

share|improve this answer

might be a problem with WINS, make sure its set to domain or workgroup on the mac according to if your windows Pc is on a domain or workgroup.

share|improve this answer

Go to System Preferences > Sharing > Internet sharing > WiFi Options and change the Security option to WPA2 personal.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.