Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to my corporate VPN using a laptop running Ubuntu 10.04. It's a company laptop but as I have chosen to run Linux rather than "a proper" OS, I'm mostly on-my-own as far as getting these things working. Normally that's OK because I am almost always successful - except this problem has had me stumped for several weeks now.

The problem is that I am unable to access the VPN from my home network. I am using the Gnome Network Manager interface to configure the PPTP connection but no matter what combination of options, domain\username formats, encryption options or authentication methods I select, I get the exact same behaviour, which is essentially a 10-second wait, and then a failure message.

I checked /var/log/daemon.log:

Aug 15 22:27:46 pc770-ubu NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.pptp'...
Aug 15 22:27:46 pc770-ubu NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.pptp' started (org.freedesktop.NetworkManager.pptp), PID 4595
Aug 15 22:27:46 pc770-ubu NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.pptp' just appeared, activating connections
Aug 15 22:27:50 pc770-ubu NetworkManager: <info>  VPN plugin state changed: 3
Aug 15 22:27:50 pc770-ubu NetworkManager: <info>  VPN connection 'VPN' (Connect) reply received.
Aug 15 22:27:50 pc770-ubu NetworkManager:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Aug 15 22:27:50 pc770-ubu NetworkManager:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Aug 15 22:27:50 pc770-ubu pptp[4602]: nm-pptp-service-4595 log[main:pptp.c:314]: The synchronous pptp option is NOT activated
Aug 15 22:27:50 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
Aug 15 22:27:50 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
Aug 15 22:27:50 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
Aug 15 22:27:51 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
Aug 15 22:27:51 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
Aug 15 22:27:51 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 17382).
[ ** TEN SECOND DELAY ** ]
Aug 15 22:28:21 pc770-ubu NetworkManager: <info>  VPN plugin failed: 1
Aug 15 22:28:21 pc770-ubu NetworkManager:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Aug 15 22:28:21 pc770-ubu pptp[4602]: nm-pptp-service-4595 warn[decaps_hdlc:pptp_gre.c:204]: short read (-1): Input/output error
Aug 15 22:28:21 pc770-ubu pptp[4602]: nm-pptp-service-4595 warn[decaps_hdlc:pptp_gre.c:216]: pppd may have shutdown, see pppd log
Aug 15 22:28:21 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[callmgr_main:pptp_callmgr.c:234]: Closing connection (unhandled)
Aug 15 22:28:21 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
Aug 15 22:28:21 pc770-ubu pptp[4609]: nm-pptp-service-4595 log[call_callback:pptp_callmgr.c:79]: Closing connection (call state)
Aug 15 22:28:21 pc770-ubu NetworkManager: <info>  VPN plugin failed: 1
Aug 15 22:28:21 pc770-ubu NetworkManager: <info>  VPN plugin failed: 1
Aug 15 22:28:21 pc770-ubu NetworkManager: <info>  VPN plugin state changed: 6
Aug 15 22:28:21 pc770-ubu NetworkManager: <info>  VPN plugin state change reason: 0
Aug 15 22:28:21 pc770-ubu NetworkManager: <WARN>  connection_state_changed(): Could not process the request because no VPN connection was active.
Aug 15 22:28:34 pc770-ubu NetworkManager: <debug> [1281868114.002900] ensure_killed(): waiting for vpn service pid 4595 to exit
Aug 15 22:28:34 pc770-ubu NetworkManager: <debug> [1281868114.002975] ensure_killed(): vpn service pid 4595 cleaned up

I was unable to determine how to enable extra debugging info in this log, so instead I manually created a very similar config for pppd and then started this with 'pon' (I've also verified that this manual configuration does connect to the VPN when I'm inside the corporate firewall):

$ sudo pon vpn debug dump logfd 2 nodetach
pppd options in effect:
debug       # (from command line)
nodetach        # (from command line)
logfd 2     # (from command line)
linkname vpn        # (from /etc/ppp/peers/vpn)
dump        # (from command line)
noauth      # (from /etc/ppp/options.pptp)
refuse-pap      # (from /etc/ppp/options.pptp)
refuse-chap     # (from /etc/ppp/options.pptp)
refuse-mschap       # (from /etc/ppp/options.pptp)
refuse-eap      # (from /etc/ppp/options.pptp)
name gnet\\dantliff     # (from /etc/ppp/peers/vpn)
remotename vpn      # (from /etc/ppp/peers/vpn)
        # (from /etc/ppp/options.pptp)
pty pptp ***.***.***.*** --nolaunchpppd         # (from /etc/ppp/peers/vpn)
crtscts     # (from /etc/ppp/options)
        # (from /etc/ppp/options)
asyncmap 0      # (from /etc/ppp/options)
lcp-echo-failure 4      # (from /etc/ppp/options)
lcp-echo-interval 30        # (from /etc/ppp/options)
hide-password       # (from /etc/ppp/options)
ipparam vpn     # (from /etc/ppp/peers/vpn)
proxyarp        # (from /etc/ppp/options)
usepeerdns      # (from /etc/ppp/peers/vpn)
nobsdcomp       # (from /etc/ppp/options.pptp)
nodeflate       # (from /etc/ppp/options.pptp)
require-mppe        # (from /etc/ppp/peers/vpn)
noipx       # (from /etc/ppp/options)
using channel 7
Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x78e7bd1c> <pcomp> <accomp>]
LCP: timeout sending Config-Requests
Connection terminated.
Modem hangup
Waiting for 1 child processes...
  script pptp ***.***.***.*** --nolaunchpppd , pid 4631
Script pptp ***.***.***.*** --nolaunchpppd  finished (pid 4631), status = 0x0

I ran Wireshark to watch the traffic and it seems that no LCP replies are coming back to the client.

A bit more info:

  • the laptop is connecting to the Internet via a WiFi access point (bridge mode), then an ADSL router. PPTP pass-through is enabled on the ADSL router and Access Point.

  • if I connect the laptop to the ADSL with an ethernet cable (to eliminate the WiFi), there is no improvement.

  • another laptop (running Mac OSX) is able to connect to the VPN, via WiFi or cable.

  • another client, Windows7, is able to connect to the VPN via cable.

  • an iPhone is able to connect to the VPN via WiFi.

  • this laptop is able to connect to the VPN from inside the corporate firewall.

So I've got three other devices that are able to connect to the target PPTP VPN, and a laptop that can't, except when I move the laptop inside the target network, it can connect.

Any ideas what else I can try? I've tried methodically selecting various VPN options with no change in result. I've also read several Ubuntu Forum posts suggesting turning off EAP and that doesn't help either. I'm now at a loss how to fix this, and what will happen next is I'll be told by Management "we told you so", drop Linux and switch to a "proper" OS like Windows instead, which I really don't want to do.

share|improve this question
add comment

6 Answers

up vote 2 down vote accepted

Never found a solution - switched to OpenVPN instead and that works fine.

share|improve this answer
add comment

I was experiencing the same problem and I think I have it solved. I had checked off "Use this connection only for resources on its network" (click Routes on the IPv4 Settings tab). Once I removed this option, my connection was able to tunnel into my VPN. My settings are as follows in the PPTP Advanced Options screen... All authentication options unchecked with the exception of MSCHAPv2.

MSCHAPv2 - not checked *
MPPE - checked *
Security - All Available *
Allow stateful encryption - not checked *
The following 3 options - checked *
ECHO packets - not checked *

I hope that ends up working for you and that you are able to keep your Ubuntu installation!

Rob

share|improve this answer
    
Thanks for the suggestion. I tried this out, along with a few other options but unfortunately it doesn't resolve my problem. I do appreciate the suggestion however. The current plan is to encourage IT to implement a trial OpenVPN service which uses straight TCP/UDP (rather than GRE etc), so we'll see how that goes. –  meowsqueak Sep 26 '10 at 0:39
    
wonderful, thank you, checking "Use this connection only for resources on its network" solved the issue for me. (issue was only present on WIFI connections) –  Zauberfisch Aug 25 '13 at 20:17
add comment

I'm running Ubuntu 10.04, I have setup 2 VPN connections one to my office and on to my client's office. The connection to my office don't work but the connection to my Client's office does.

I believe the problem is on the Microsoft Server.

share|improve this answer
add comment

You should adjust your configuration like this

enter image description here

share|improve this answer
    
Thanks, but that would have been the first thing I tried, before I resorted to manually hacking configuration files. As it is right now, I no longer have access to that VPN, and OpenVPN was working far better until I left anyway. –  meowsqueak Feb 2 '13 at 22:10
    
inficode.com/blog/install-ppp-pptpd-vpn-server-on-rhel-centos make a clean install from link and configure as above. thank you –  xy_ Jul 1 '13 at 19:07
add comment

I concluded that the cause of this problem is the network I am connected to, rather than anything in my own laptop or the workplace VPN. (AirPort Wi-Fi dropping VPN-related packets? Ugh!)

This post and my own observations support this conclusion.

Finally I realized that I had checked the GRE/PPTP box under Tracking/NAT helpers (in Tomato WebGUI, go to Advanced->Conntrack/Netfilter, then scroll down to Tracking/NAT helpers) but the default state was unchecked.

So I unchecked it, and VPN started working again!

share|improve this answer
    
Thanks for the link, but it would be better to also post a summary of the answer here as links can break. –  Dour High Arch Aug 23 '13 at 14:34
    
I took a guess at what the most important part of that forum thread was, but if that wasn't the right one, please edit your post and include the essential information here. We don't want to send people to another site to find the answer in a forum thread. –  slhck Aug 23 '13 at 14:50
    
Would it be appropriate to change my answer to this? > My network was dropping GRE packets, and my logs looked just like above. –  daveloyall Aug 27 '13 at 21:27
add comment

I have the same issues with my company laptop. I've been using Debian Lenny for about a year. I get around those Linux limitations by running Microsoft Windows in a VirtualBox VM. I can VPN into our corporate office inside the VM. That lets me access the corporate network from inside the VM, but not from the Linux host.

share|improve this answer
    
Thanks for your comment - I tried this out (WinXP inside a VirtualBox VM) and what do you know? It actually works! This means that my LAN is not the problem. Now we've got: Windows7, works; Mac OSX, works; iPhone, works; WinXP in VirtualBox VM on Ubuntu, works; but native Ubuntu does not work. I really wish I knew why. It may be useful to note that other people have the same laptop model, running the same Linux version, and do not have this problem. I am on my own. –  meowsqueak Aug 18 '10 at 8:16
    
I've also tried a brand-new VPN configuration, with default settings, and it doesn't work either. –  meowsqueak Aug 18 '10 at 8:21
    
My VPN connection uses a .pcf file for the connection settings, which I should be able to use to make my VPN connection work from Debian. (I just haven't made that high on my todo list.) Do you have access to a similar settings file for your VPN connection? That might help confirm what the settings should be. –  Tom Aug 18 '10 at 18:23
    
I don't have access to a .pcf file, but I have been able to verify that the settings are correct. My configuration matches other users' exactly, yet for some reason they can use the VPN but I cannot. There's something fundamentally wrong with VPN operation on this host, and it might be interacting with something slightly wrong with the external network configuration. –  meowsqueak Aug 23 '10 at 22:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.