Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

UPnP has been a bit unreliable (sometimes benefiting from rebooting the DSL modem). It's currently working with programs which need to open ports but it's still not showing up in Network Connections or My Network Places, even though it did at first - after I installed "UPnP User Interface" (which only gives you an icon and some minimal information) in the Windows Components Wizard.

For general networking, there are many tools (both GUI and commandline) built in to Windows to diagnose problems and refresh and reconfigure the network adapters. With UPnP however, there seems to be nothing.

My question is:

How can you diagnose problems and configure UPnP on Windows?

Specifically, I'd like to be able to:

  • refresh Windows's view of UPnP devices / force re-discovery (when it's working, the DSL modem shows up as a gateway in both Network Connections and My Network Places)
  • probe a device for UPnP availability, similar to ping or telnet (since I know its IP address)
  • anything else useful

preferably using Windows (XP)'s native facilities.

share|improve this question

I found this tool concerning UPnP troubleshooting :

I never tested this application, so i don't guarantee it will work. But hey, at least it's a start to do some debuging. I would also recommend to check in the various logs you can get a hold on. Activating WMI and searching through it may be a good start.

That also applies to your Modem/equipment you want to pass through.

Sorry but i can't be more specific since we don't have much details in term of the hardware your using.

PS: has a lot of interesting advices for various equipments.

share|improve this answer
I suppose you linked to the addictivetips site because the actual program homepage is down? – Hugh Allen Oct 9 '12 at 0:52
Yes. I should have maybe tried to find a working link for it. But i don't really have time at the moment. – TeT Oct 12 '12 at 9:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .