Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use constantly. When connecting via ssh to remote *nix systems, I can continue to use tab to complete command names and arrow-up/down to navigate the command history. However, with sftp this does not work, and I get [-escaped sequences for the latter and a literal tab for the former.

Any way to get this to work? Anything to do with readline?

share|improve this question
up vote 3 down vote accepted

Check out with-readline. There's an example using sftp there.

share|improve this answer

Having tried to install with-readline on OSX 10.7.5 I ran into linker errors.

While trying to find a solution to this problem I discovered that MacPorts has a port of OpenSSH which includes the sftp utility compiled with readline support. MacPorts also sets this version of sftp as the default.

share|improve this answer

You can also try yafc.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.