Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed IIS7, but whenever I want to start it, the following error occurs:

Cannot start service W3SVC on computer '.'

What's wrong with it ?

I have Windows 7 64-bit build 7600 and have installed .NET Framework 3.5 SP1 and .NET Framework 4 before installing IIS7.

share|improve this question
Does the Event Log have anything to add to the error? This thread may help: – BillP3rd Aug 16 '10 at 20:23

13 Answers 13

up vote 11 down vote accepted

I found the solution:

  1. Run -> appwiz.cpl -> Turn windows features on or off -> Uncheck "Internet Information Services" and "Windows Process Activation Service"

  2. Restart your machine.

  3. Run -> appwiz.cpl -> install both "Internet Information Services" and "Windows Process Activation Service"


share|improve this answer
Where is "Internet Information Services" inside "Turn windows features on or off"> I can not find it. – Alvaro Jun 16 '15 at 9:53

Go to Task Manager --> Processes and manually stop the W3SVC process. After doing this the process should start normally when restarting IIS

share|improve this answer
It's svchost, so go to Services, Right-Click, Go To Process to find the right svchost to terminate. – Travis Aug 21 '13 at 17:26
This is a better solution and doesn't need restart. – nima Oct 10 '13 at 21:09
It's w3wp.exe in my case. – yazanpro May 19 at 22:15

This commonly occurs when port 80 is being used by something else. If this is a dev box, do you also have Apache or Skype installed? These are a common culprit.

You can check if port 80 is in use by running netstat -ab|find "80" in an elevated command prompt. This may take a minute or two to run depending on what network activity is occurring on your PC.

share|improve this answer
Thanks for the reply, I've done what you said and this is the result : – Mohammad Dayyan Aug 16 '10 at 19:32
BTW: I've been installed Apache and Mysql via XAMPP on my system before installing IIS7. – Mohammad Dayyan Aug 16 '10 at 19:34
It doesn't look like anything is running on port 80 there. What does your event log say? – MDMarra Aug 16 '10 at 19:51
How should I check event logs? – Mohammad Dayyan Aug 17 '10 at 0:38
@Mohammad - Perhaps this question is better suited for – MDMarra Aug 17 '10 at 0:52

A bit different from Mohammad's solution:

  1. Run -> appwiz.cpl -> Turn windows features on or off -> Check "Windows Process Activation Service"

  2. That's all.

It solved my problem.

share|improve this answer
This actually didn't work for me but Mohammad's did. Just sayin' – Vazgen Dec 23 '12 at 20:19
This worked once I manually started the service after installation. No reboot required. – kampsj Mar 17 '14 at 14:20

The solution to this issue was different for me.

After following the solutions to check that the Window Features where there I was still having the same problem.

The error message was the same and I noticed the Windows Service "World Wide Web Publishing Service" which was set to automatic was not started.

This service was dependent on "Windows Process Activation Service" (You can check dependent services by right clicking > properties > dependent tab)

I received a file/assembly missing error when I tried to manually start "Windows Process Activation Service". According to this blog the apppools folder had gone missing. Like the author of that page I have no idea what caused it to software?

I added the directory c:\inetpub\temp\apppools and started the services in the correct order. Both are now set to automatic and all work fine.

share|improve this answer
This is actually the only solution which worked for me! And yes it all worked before, but needed to disable the services for Xamp. – Henk-Martijn May 17 at 14:48

I had this issue because I forgot I was debugging the w3svc process in Visual Studio when working on a website, and I was paused at a breakpoint. :P

share|improve this answer
  1. Go to services.msc
  2. Check World Wide Web Publishing Service.
  3. If disabled, right-click change the Startup type to Automatic.
  4. Start the service.
share|improve this answer

You should check to see that all of the following services are started, or at the very least, not disabled: HTTP, Windows Process Activation Service, DCOM Process Launcher, and RPC Endpoint Mapper.

You should also verify t hat no other process is listening on port 80. The simplest way to do this is to issue the following in a command window:

netstat -a -o|findstr 80
share|improve this answer
With the default settings Skype also uses ports 80 and 443 as an alternative for incoming connections. Check whether this is enabled in the advanced->connection settings if you have installed Skype. – Andreas Aug 16 '10 at 21:05
I've checked port 80 via the command that you wrote , this is the result => – Mohammad Dayyan Aug 17 '10 at 0:34
BTW, I don't have Skype – Mohammad Dayyan Aug 17 '10 at 0:35
I've checked the services that you wrote, I don't have a service with HTTP name. DCOM Process Launcher and RPC Endpoint Mapper are started but Windows Process Activation Service is in Manual mode and it didn't start. When I wanted to start it this error has occurred : – Mohammad Dayyan Aug 17 '10 at 0:41
This should help:… The short answer is to check for a folder called C:\inetpub\temp\appPools. If it doesn't exist, create it. Also: – BillP3rd Aug 17 '10 at 3:01

I was having the same issue, and followed all the steps described here.... However, nothing seems to worked.

The error in the event manager I was getting while trying to run "Windows Process Activation Service" service manually was stating that http service was not found or disabled. Moreover, we were not able to find http service in services list.. so wasn't sure how to enable it.

Here is the error I was getting

The World Wide Web Publishing Service service depends on the HTTP service which failed to start because of the following error: 
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Finally I got it fixed using following command in command prompt.

sc config http start= auto

Then, just started "Windows Process Activation Service" and IIS is now running fine.

Credit goes to the original answer given here: How to re-install http windows service by MajidTaheri

Hoping this helps someone with the same issue...

share|improve this answer

I came across the same problem. It got solved with following steps:

  1. Go to admin dos command prompt --
  2. (Ctrl+x) will give the option to go to admin dos prompt
  3. use command "iisreset"

This will solve the problem.

Thanks, Narendra.

share|improve this answer

I had a similar issue. In my case, World Wide Web Publushing Service (W3SVC) service was disabled. Run services.msc, right-click on World Wide Web Publushing Service, then click Properties and select "Automatic" as startup type. Now start IIS again.

share|improve this answer

Just rebooted the server. It was fine then. The service was stuck trying to come down after I made some IIS changes.

share|improve this answer

After upgrading from Server 2010 to 2012 R2 I had the same issue. I followed the advice above with the additional steps.

From elevated command prompt:

sc config http start = auto
net start w3svc

Refreshed the WSUS website in IIS manager and restarted and things were good.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .