Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed IIS7, but whenever I want to start it, the following error occurs:

Cannot start service W3SVC on computer '.'

What's wrong with it ?

I have Windows 7 64-bit build 7600 and have installed .NET Framework 3.5 SP1 and .NET Framework 4 before installing IIS7.

share|improve this question
    
Does the Event Log have anything to add to the error? This thread may help: forums.iis.net/t/1151484.aspx –  BillP3rd Aug 16 '10 at 20:23

9 Answers 9

up vote 8 down vote accepted

I found the solution:

  1. Run -> appwiz.cpl -> Turn windows features on or off -> Uncheck "Internet Information Services" and "Windows Process Activation Service"

  2. Restart your machine.

  3. Run -> appwiz.cpl -> install both "Internet Information Services" and "Windows Process Activation Service"

Reference

share|improve this answer

Go to Task Manager --> Processes and manually stop the W3SVC process. After doing this the process should start normally when restarting IIS

share|improve this answer
    
It's svchost, so go to Services, Right-Click, Go To Process to find the right svchost to terminate. –  Travis Aug 21 '13 at 17:26
    
This is a better solution and doesn't need restart. –  nima Oct 10 '13 at 21:09

A bit different from Mohammad's solution:

  1. Run -> appwiz.cpl -> Turn windows features on or off -> Check "Windows Process Activation Service"

  2. That's all.

It solved my problem.

share|improve this answer
    
This actually didn't work for me but Mohammad's did. Just sayin' –  Vazgen Dec 23 '12 at 20:19
    
This worked once I manually started the service after installation. No reboot required. –  kampsj Mar 17 at 14:20

This commonly occurs when port 80 is being used by something else. If this is a dev box, do you also have Apache or Skype installed? These are a common culprit.

You can check if port 80 is in use by running netstat -ab|find "80" in an elevated command prompt. This may take a minute or two to run depending on what network activity is occurring on your PC.

share|improve this answer
    
Thanks for the reply, I've done what you said and this is the result : picfront.org/d/7Mdg –  Mohammad Aug 16 '10 at 19:32
    
BTW: I've been installed Apache and Mysql via XAMPP on my system before installing IIS7. –  Mohammad Aug 16 '10 at 19:34
    
It doesn't look like anything is running on port 80 there. What does your event log say? –  MDMarra Aug 16 '10 at 19:51
    
How should I check event logs? –  Mohammad Aug 17 '10 at 0:38
    
@Mohammad - Perhaps this question is better suited for superuser.com –  MDMarra Aug 17 '10 at 0:52

You should check to see that all of the following services are started, or at the very least, not disabled: HTTP, Windows Process Activation Service, DCOM Process Launcher, and RPC Endpoint Mapper.

You should also verify t hat no other process is listening on port 80. The simplest way to do this is to issue the following in a command window:

netstat -a -o|findstr 80
share|improve this answer
    
With the default settings Skype also uses ports 80 and 443 as an alternative for incoming connections. Check whether this is enabled in the advanced->connection settings if you have installed Skype. –  Andreas Aug 16 '10 at 21:05
    
I've checked port 80 via the command that you wrote , this is the result => picfront.org/d/7Mdg –  Mohammad Aug 17 '10 at 0:34
    
BTW, I don't have Skype –  Mohammad Aug 17 '10 at 0:35
    
I've checked the services that you wrote, I don't have a service with HTTP name. DCOM Process Launcher and RPC Endpoint Mapper are started but Windows Process Activation Service is in Manual mode and it didn't start. When I wanted to start it this error has occurred : picfront.org/d/7MeM –  Mohammad Aug 17 '10 at 0:41
    
This should help: hanselman.com/blog/… The short answer is to check for a folder called C:\inetpub\temp\appPools. If it doesn't exist, create it. Also: technet.microsoft.com/en-us/library/cc734935(WS.10).aspx –  BillP3rd Aug 17 '10 at 3:01

I had a similar issue. In my case, World Wide Web Publushing Service (W3SVC) service was disabled. Run services.msc, right-click on World Wide Web Publushing Service, then click Properties and select "Automatic" as startup type. Now start IIS again.

share|improve this answer

The solution to this issue was different for me.

After following the solutions to check that the Window Features where there I was still having the same problem.

The error message was the same and I noticed the Windows Service "World Wide Web Publishing Service" which was set to automatic was not started.

This service was dependent on "Windows Process Activation Service" (You can check dependent services by right clicking > properties > dependent tab)

I received a file/assembly missing error when I tried to manually start "Windows Process Activation Service". According to this blog the apppools folder had gone missing. Like the author of that page I have no idea what caused it to disappear...security software?

I added the directory c:\inetpub\temp\apppools and started the services in the correct order. Both are now set to automatic and all work fine.

share|improve this answer

I was having the same issue, and followed all the steps described here.... However, nothing seems to worked.

The error in the event manager I was getting while trying to run "Windows Process Activation Service" service manually was stating that http service was not found or disabled. Moreover, we were not able to find http service in services list.. so wasn't sure how to enable it.

Here is the error I was getting

The World Wide Web Publishing Service service depends on the HTTP service which failed to start because of the following error: 
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Finally I got it fixed using following command in command prompt.

sc config http start= auto

Then, just started "Windows Process Activation Service" and IIS is now running fine.

Credit goes to the original answer given here: How to re-install http windows service by MajidTaheri

Hoping this helps someone with the same issue...

share|improve this answer

Just rebooted the server. It was fine then. The service was stuck trying to come down after I made some IIS changes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.