Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I run a process that requires a UAC confirmation from the user, the Windows UAC prompt appears and waits for the user to confirm the action. With the UAC prompt open, if I look at the list of running processes, the original application appears.

What state is this process in? Presumably it has started running as it appears as a process, but it cannot have done anything yet as that would surely defeat the purpose of UAC.

share|improve this question
    
Do you mean a process that has the elevation required flag set in it's manifest, or a process that requests elevation after it starts? –  Hello71 Aug 17 '10 at 2:22
    
@Hello71: The second case. The process has tried to do something that requires administrative rights. –  adrianbanks Aug 17 '10 at 9:10
    
Is UAC virtualization enabled for the process? –  Hello71 Aug 17 '10 at 14:42
    
@Hello71: No, it is not. –  adrianbanks Aug 17 '10 at 23:07
    
Then the process has to explicitly request elevation, and the thread requesting elevation is blocked until the call returns. Same as any other waiting call (networking, for example). –  Hello71 Aug 17 '10 at 23:37

2 Answers 2

The process is given an ID ready for launch, if you block access the process is terminated, the process is just in memory but contains no data until allow is pressed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.