Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 10.04 to access a Windows VPN. I connect to the VPN from Ubuntu, and when I open a Windows 7 virtual machine (VirtualBox), everything works great ... I can access local network drives, ping local servers, remote into local machines, etc.

However, I can do none of this from Ubuntu. With the VPN connected, I cannot even ping anything within the VPN local network. I'm guessing it's a DNS issue that Windows is handling automatically but Ubuntu needs a setting somewhere to tell it to use the DNS servers of the VPN network?

Any ideas? I'm a relative novice to Ubuntu, esp. VPN in Ubuntu.

[EDIT] Actually, I'm almost positive it is DNS, because if I get the IP address from the Windows VM I can use Terminal Server Client to remote into a machine.

share|improve this question
up vote 1 down vote accepted

I had the same problem, and it was a routing issue. When you connect to the Windows VPN, the routes are not automatically added.

Here's what I did in 10.10 under the "IPv4 Settings" tab of the Network Manager's VPN config dialog. Hopefully, it will apply equally to 10.04.

  1. Selected Method "Automatic (VPN) addresses only"
  2. Specified DNS server IP's separated by comma
  3. Added our office's standard parent domain under "Search domains". (I'm not sure this matters because all my DNS lookups use the servers specified in #3 while connected to the VPN.)
  4. Clicked the "Routes..." button to open the routes dialog.
  5. Added a route for VPN addresses through the "Routes..." dialog.
  6. Example route: Address=, Netmask=, Gateway=
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .