Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When switching spaces I find there is this really annoying bug that keeps causing windows on the destination space to be in front of the window that's currently focussed. The correct window gets the focus but is hidden by the rogue front app.

As an example, if I have one space with Safari and Mail, another space with terminal which is currently focussed, if I CMD+TAB to Safari the following occurs:

  • Spaces will switch to the correct destination space
  • Safari will be the focussed window
  • Mail will be in front of Safari (intermittent)

I find this really frustrating and I find I have to CMD+TAB back again to correct the window layers.

Anyone know a solution to resolve this?

share|improve this question
add comment

4 Answers 4

Spaces has been completely redesigned in the current Lion DP, and while it's still very buggy, it doesn't seem to have that particular quirk anymore.

So one more non-solution: wait for 10.7.

share|improve this answer
add comment

Another non-solution that I personally use: switch between windows using Witch, a nice third-party app that lets you select the focused window with the keyboard only. That works well for the people allergic to Expose like me. And no, I've no financial interest in the software company (Many Tricks) that sells Witch...

share|improve this answer
add comment

For me the solution was to disable spaces. It’s annoying when you really want to use the keyboard only. Spaces forces you to use the mouse (maybe not spaces but OS X in general) a lot of times.

I grabbed a copy of Size Up and got used to organize my windows that way.

share|improve this answer
    
Hi Martin, thanks for the advice. I don't think I've be able to use SizeUp, I use and lie spaces due to being able to organise my focus within each space. I hate seeing windows too close to the edges of the screen and very rarely maximise a window, the only one being my IDE. –  Brett Ryan Aug 18 '10 at 10:14
add comment

The real solution is to use spaces & expose "elegantly". I have my bottom left hot spot designated for spaces & my top left hot spot designated as expose. This way I can easily pull apart and select the application I need. What your using is called the "Application Switcher" not a part of or connected to spaces in anyway. Your application switcher will take you to where that application is w/ out bringing it forward, however if you activate spaces, select what window you want, then use expose to bring the application forward or simply click on it's icon in the doc. Personally I use my mouse touch pad a lot, I'm taking it your a keyboard guy from windows land? The application switcher was put there for backward compatible pc users. If you want to use the keyboard there are function keys that are associated w/ spaces / expose under system preferences.

share|improve this answer
    
Hi, I'm actually a keyboard user from a Unix background, the "Virtual Desktops" feature which Spaces is akin to does not emit this behaviour. I still think this is a but in OSX however, as when I switch to the app within the space, if it was previously the top most something is still putting it behind the other windows, why? No reasoning. –  Brett Ryan Mar 8 '11 at 7:31
1  
Also, I don't use the mouse much for two reasons. 1. I'm nearly blind and can't see it, 2. I have CTS and it hurts to use a mouse for too much. I don't think that the application switcher is a backwards compatibility feature, it's always been apart of MacOS, I can't remember from v7 and 8, but it was there when I was using v9. –  Brett Ryan Mar 8 '11 at 7:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.