Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 Starter on an Acer Aspire One laptop.

I want my laptop to automatically run a task (backup the HDD to a network drive) once a week in the middle of the night. I scheduled the task in "Task Scheduler" and checked the box to wake the computer to run the task. I also changed the advanced power settings to allow wake timers. This was half of the solution. It now works flawlessly when the lid is open... the computer can wake itself up from either sleep or hibernate mode to perform the backup. When the lid is closed however, its sleeping beauty.

Any ideas? I don't want to have to remember to open the lid once a week. It sort of defeats the purpose of an "automatic" backup.

Update: I discovered that it can wake from sleep (or hybrid sleep), but not from hibernate when the lid is closed. This is good news. I'd still be curious about how to get it to work from hibernate, but I'm pretty happy about waking from sleep at least.

share|improve this question
    
I cannot recommend against hibernate strongly enough. –  Kara Marfia Aug 17 '10 at 2:26
    
OK, thanks for the advice. Maybe I'll just stick with sleep. I was thinking that hibernate would help my battery last several times longer, but I guess it will last long enough in sleep mode. –  JD Pack Aug 17 '10 at 3:18
1  
Hybrid sleep is hibernate. It starts out going into standby where everything but the RAM is shut down, then after a while, it saves the RAM to disk and turns off altogether. You can see the difference because in sleep mode, pressing a key turns it back on, but if you leave it long enough and it hits hibernation mode, you must press the power-button to turn it on. –  Synetech Jul 28 '12 at 13:10
    
Running Windows 8.0 I have a similar problem. For me, though, the laptop actual does wake from sleep and run the scheduled task but the wireless network card does not work when the lid is closed. Since you're connecting to a network drive, this sounds like the same problem. Were you wired or wireless? And did you have to do anything to get the wireless NIC to turn back on? –  cod3monk3y Jan 17 at 16:02

3 Answers 3

It sounds like you have Windows 7 set to sleep when the lid is closed and perhaps this is what's preventing it from waking. In Control Panel choose Power Options. On the left side, click "Choose what closing the lid does." I'd set "When I close the lid" / "Plugged in" = Do Nothing.

share|improve this answer
    
Thanks a lot for the suggestion! I should have mentioned that I had already tried this and it didn't work. :-( –  JD Pack Aug 17 '10 at 1:36
    
Glad you got it working from sleep mode. FWIW, I don't use hibernate. I always sleep my laptop (post XP, another story). Since (I assume) your laptop is plugged in, you don't have to worry about exhausting the battery in sleep. Also, you could set up your backup to run then put the laptop back to sleep upon completion. –  BillP3rd Aug 17 '10 at 3:17

The lid may override the sleep settings. Happens on MacBooks as well. The solution on that platform is InsomniaX. Being as the hardware is different, I'm not sure if there is a solution.

share|improve this answer

In advanced power setting set the wake timer "on" for AC and/or Battery mode. Once this is set a scheduled task can be set to wake computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.