Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Setup: I have Windows 7 running inside VirtualBox on Mac OS X host. I have a shared drive with some HTML files, that I am mounting as a local drive W: in Windows, from the VirtualBox server \VBOXSVR. I want to look at them with a browser in Windows.

Chrome in Windows 7 opens and shows those HTML files just fine (file:///W:/welcome.html). But Internet Explorer does not, and shows this error instead of the files:

Internet Explorer cannot display the web page

What you can try: [button Diagnose Connection Problems]

More information

This problem can be caused by a variety of issues, including:

  • Internet connectivity has been lost.
  • The website is temporarily unavailable.
  • The Domain Name Server (DNS) is not reachable.
  • The Domain Name Server (DNS) does not have a listing for the website's domain.
  • If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

For the internet zone in the status bar, it shows:

Internet | Protected Mode: On

IE settings are a mystery to me, and I could possibly get it to work by tweaking IE settings, but I don't know which ones.

How do I make IE show the same files that Chrome is happy to show? (Chrome showing them means that the files themselves are fine, there is something about the setup that just makes IE be a diva.)

share|improve this question
add comment

6 Answers 6

That error page is kind of weird, but here's a crack at it:

If you map the drive by IP address (or by a FQDN that isn't your domain), the mapped drive will be identified as untrusted (aka Internet Zone).

If you map it by name (\\VBOXSVR\Sharename), and it's still not being auto-recognized as Intranet, then you can add VBOXSRV to the Intranet site list in IE manually (Internet Options-->Security-->Local Intranet-->Sites).

Hopefully that'll help you out.

share|improve this answer
    
Thanks, this did not work. The Windows image is set up with a corporate security/firewall software that I cannot configure. I am starting to think that this software is messing with me. –  Jaanus Aug 18 '10 at 2:21
add comment

Try this: on the IE menu, Tools > Internet Options > Security tab. Click Local Intranet. Click the Sites button. You should see a set of checkboxes. Make sure Automatically detect and Include all network paths are enabled.

share|improve this answer
    
Didn't help :( did this but still the same. –  Jaanus Aug 18 '10 at 2:22
    
Once you've made the change, does IE show the page in question (W:/welcome.html) as being in the Local Intranet zone? There should be an indicator at the bottom, in the status bar. –  boot13 Aug 18 '10 at 18:26
add comment

Why don't you try co copy the files on your windows partition (create a folder on your desktop and drag them there)...

share|improve this answer
add comment

Works for me:

enter image description here

And i've not configured anything strange in Internet Explorer. Just to be sure we're on the same page (so to speak):

  • reset security settings to medium:

    enter image description here

  • reset advanced settings to default

    enter image description here

  • possibly even reset IE to factory settings:

    enter image description here

But your next step is to make sure the welcome.html renders fine off a local drive; and then run Process Monitor to watch Internet Explorer read the file, and make sure there isn't any Access Denied or some such nonsense.

My psychic debugging tells me that you have some anti-virus malware that is deciding to "protect" Internet Explorer from reading files of the network zone.

share|improve this answer
add comment

If you can modify the file, you can try tricking IE with MOTW to put it in the Internet Zone, http://msdn.microsoft.com/en-us/library/ms537628(v=vs.85).aspx.

Basically add this line to the beginning of the HTML file:

<!-- saved from url=(0014)about:internet -->

You could also try forcing it into Intranet Zone but that depends on whether you have protected mode on or not for that zone. This would get you Intranet Zone:

<!-- saved from url=(0016)http://localhost -->

Be sure the file is saved with Windows line breaks (CR+LF). If you have Text Wrangler you can specify windows line breaks when you save the file.

Finally, another way to use MOTW would require using NTFS Alternate Data Streams (http://stackoverflow.com/questions/4496697/what-is-zone-identifier). Basically, go to the windows command prompt and type

notepad W:\Welcome.html:Zone.Identifier

In the text file put the following:

[ZoneTransfer]
ZoneId=2

For any of these methods you'll need to completely close IE and reopen for MOTW to behave properly.

share|improve this answer
add comment

I had the same setup and problem:

  • Windows 7 in Virtualbox on Mac OS X host.
  • HTML files in shared folder (\vbozsvr\mySharedFolder) open in Chrome but not in IE10

Problem solved by the following settings in IE10

In Internet Options -> Security:

Internet - Security level "Medium", uncheck "Enable Protected Mode"

Local Intranet - Security level "Low", uncheck "Enable Protected Mode"

Trusted sites - Security level "Low", uncheck "Enable Protected Mode". Also, click the "Sites" button, uncheck the "Require server verification" box, and add "file://vboxsvr" to the list of trusted sites.

share|improve this answer
    
wouldnt it simply be better to add yourself as trusted? reducing security should be a no-no. –  Lorenzo Von Matterhorn Sep 19 '13 at 10:23
    
Yup, I realize this is not a good solution (Although I only use these settings when I visit sites that I control myself, for web dev testing puroses). Sorry for being noob: could you please clarify what you mean by "add yourself as trusted"? Thanks! –  camelBase Sep 19 '13 at 16:09
    
i meant this: superuser.com/a/149076/179299 –  Lorenzo Von Matterhorn Sep 19 '13 at 18:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.