Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am baffled...NIC on Precision 690 not working. Just bought so do not know history. Installed Windows 7. I have:

  1. tried different cables and confirmed that cables are not the problem
  2. Tried removing the device and rebooting

Dell diagnostic says NIC is fine. Windows 7 has installed NIC and says everything is fine. However, when I plug in a cable nothing happens. No lights light up when a cable is plugged in.

Bios is A08.

Got ideas?

share|improve this question

3 Answers 3

Is there more than one Ethernet port on the computer? Open it up and see if the port you're using is connected to something: it will either be physically part of a NIC card, or there will be a cable that runs to the motherboard. Also: go into the BIOS setup. Look for a section for onboard peripherals. If a NIC is shown, check to make sure it's enabled.

share|improve this answer
    
Thanks! I double checked the BIOS and the NIC in enabled. The NIC is on the motherboard so nothing to hook up or unhook. –  burkesquires Aug 19 '10 at 4:00
    
It could be the ethernet port on the motherboard. Ports that are attached to a motherboard and accessed from outside the case are subject to a certain amount of flexing in normal use. Broken traces sometimes result. Depending on the thoroughness of the diagnostic, the NIC could still pass with this kind of fault. Some NIC diagnostics include a cable test which would flag this kind of problem. Does the diagnostic program have any more tests that maybe you didn't run earlier? Unfortunately, if I'm right, this would be fairly difficult to repair, so maybe just add another NIC. –  boot13 Aug 19 '10 at 6:20

It really does sound like your NIC is okay, so perhaps the problem is elsewhere. I know this sounds silly but ...

  • Check the other end of the LAN cable -- is it connected to anything?
  • Try a different LAN cable. Perhaps that one is broken.
share|improve this answer
    
Thanks! I just double checked with a working cable to another NIC in the computer and the NIC still does not light up. –  burkesquires Aug 19 '10 at 4:01
    
Sorry, could you clarify that last comment? You added another NIC to the computer and connected it to the first NIC with a known good cable, and the link light didn't turn on? –  boot13 Aug 19 '10 at 6:14

Only thing I can suggest it to install the Vista driver, see if it helps the issue

http://support.dell.com/support/downloads/driverslist.aspx?os=WLH&catid=-1&dateid=-1&impid=-1&osl=EN&typeid=-1&formatid=-1&servicetag=&SystemID=LATITUDE+PRECISION+690&hidos=WW1&hidlang=en&TabIndex=&scanSupported=False&scanConsent=False

choose Vista 32 or 64bit at the top under Refine Your Results

share|improve this answer
    
Hello...tried Vista drivers and no luck. I am using a PCI network card for now but would rather not if I do not have to. Thanks though! –  burkesquires Aug 19 '10 at 4:00
    
Only other thing I can think of is to flash the bios to the latest version if it is not already. Other than that the NIC may be dead. –  Moab Aug 19 '10 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.