Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
No Question mark suddenly É instead. Why?

I know what when you press Ctrl+Shift it will fix it but only momentarily. It will change back as soon as you change the program that you are in? What can I do? I have tryed to change the language of my keyboard but it doenst help. What should I change it to? I have tried English Canada and English US.

share|improve this question

marked as duplicate by Ivo Flipse Aug 17 '10 at 16:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I edited the tags. –  Torben Gundtofte-Bruun Aug 17 '10 at 7:03

2 Answers 2

You're accidentally changing it to French Canadian and having to change it back to the US or Canadian English keyboard/language settings.

First thing I always do is go in and remove all the shortcut keys to change the language settings as I'll just manually change them with the menu/control panel if/when I want to change them. You can also try removing any languages or keyboards that you won't use.

You can change/edit the settings by right clicking on the settings if you have the language bar near your taskbar. The other way to get to the language and keyboard settings is to go to the Control Panel from the start menu.

Personally as a bilingual French Canadian, I keep my keyboard setup to US international and Language setting to Canadian English.

share|improve this answer
    
suggested by anonymous user: "There is a keyboard on the right-hand side of your task bar. Click on it and then click 'US'." –  Excellll Aug 13 '12 at 19:19

It appears that you have your keyboard setup for French or some European language.

Here is a UbuntuForums discussion on a similar case seen in Ubuntu,

Pressing shift+4 should give you a question mark, or maybe it's shift+6, I can't remember. But if either of those do it, you've got the French layout on.

Here is another similar case on French keyboard getting activated.

I figured out why this goes on so frequently. There’s a keyboard combination that switches languages. Mine was set to Ctrl-Alt which gets hit occasionally. There’s two ways to turn it off

  1. Near the bottom right of the screen is an icon of a keyboard. Left click and select US keyboard if it’s set to French. This turns it off but it doesn’t prevent it from getting switched again.

  2. The permanent fix is to disable the key combination. There’s two ways to do this.

    • Right click on the keyboard icon and left click Settings.
    • Select the “Advanced Key Settings” tab.
    • Click the “Change Key Sequence” button and select “not assigned”.
    • Click OK a few times and you’re done.
  3. If you cannot locate the keyboard icon you can get at this through the control panel.

    • Go to Regional and Language control panel.
    • Select the keyboards and languages tab and click the change keyboards button.
    • This takes you to the language settings described in step 2 above.

I made some mild formatting changes to that quoted block for easier reading

share|improve this answer
    
Permanent fix helped. Thanks for the clear step by step instruction! This answer is more clear than the linked duplicate. –  Timothy Onggowasito Jun 23 at 13:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.