Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am able to surf the web and my LogMeIn client is not reporting any errors, but I cannot connect to or Steam. (I can still visit and Steam via my web browser.)

I was actually logged into BOTH of these services earlier this morning, but now they will not connect. (For those who do not game: these services are unrelated and hosted by two separate companies.)

Steam is temporarily unavailable, please try later The game is awaiting a response from The service may be temporarily unavailable or your internet connection may be down. If you are not connected in a few moments, please check your internet connection and try again.

My setup:

  • Comcast Cable Internet
  • Motorolla SB6120 DOCSIS 3.0 Modem
  • Gentoo Router (built years ago following this guide)
  • Dell PowerConnect 2724 24-port gigabit switch
  • Windows 2003 Domain Controller / DNS Server (recursing to OpenDNS)
  • Windows 7 x64 desktop computer (where I am attempting to access the games from.)
  • There is absolutely no antivirus or security software running on my gaming computer.

Steps I have taken:

  • Rebooted modem, router, domain controller and desktop computer.
  • Tried removing OpenDNS and using my ISP's DNS from the Domain Controller
  • Tried changing DNS on my client computer to my ISP's DNS (normally, my computer's only DNS entry is the DC).
  • Double checked that the Windows Firewall was in fact still disabled for all profiles.
  • Double checked that Windows Defender is still turned off.

I am completely perplexed and not sure what to try next? Has anyone seen this before?


  • I called Comcast (they are not blocking any gaming services)
  • I installed Steam on another computer in my house and it CONNECTS
  • I tried to do a System Restore to a random checkpoint made last week (did not fix it.)
  • I am thinking the Windows Firewall is somehow misbehaving. After the system restore, I went into check the firewall settings again and it told me that the snap in could not load because the Windows Firewall was not running. Once I started the Firewall service, I enabled and disabled the firewalls. Still cannot connect to Steam or, though.

And I got this message when trying to do a repair install on Steam: Error 1316: A network error occurred while attempting to read from the file...

share|improve this question
Nope, but I think it's a great question – Ivo Flipse Aug 17 '10 at 13:47
I agree, this is bizarre. I would almost think the ports were closed but you've already checked that software firewalling is sure your router isn't possibly firewalling this? – Shinrai Aug 17 '10 at 14:09
...actually, no, that would make no sense, it worked this morning. I am totally perplexed. – Shinrai Aug 17 '10 at 14:09

Try TCPView to check if the connections themself can be made.
Try to do a similar logging activity on your Gentoo router.

This should tell you more exactly were the problem lies, as that is the first thing you should be after.

References that might be interesting as they contain the ports they use and other tips:

LogMeIn uses port 80, 443 (that's just like browsing, might explain why logging in works) and 2002.

share|improve this answer
When I start Steam, it doesn't even show up in TCPView? – James Watt Aug 17 '10 at 14:44
Hmm, then I would guess the problem lies on your computer... Try netsh int ip reset and netsh winsock reset to be sure that those stacks are fine. In the device manager, go to the properties of your network adapter and check device upper filters under the details tab to see if there is something extra-ordinary filtering. – Tom Wijsman Aug 17 '10 at 14:55
Solution to Error 1316 in Steam: – Tom Wijsman Aug 17 '10 at 14:59
Although that might help to fix the installation, I don't think that the last fix I mentioned will help towards the whole issue. – Tom Wijsman Aug 17 '10 at 15:00
The System Restore rules out a lot of other possible configuration changes, the Windows Firewall will not interrupt anything if you just set the service to disabled. Anyway, good luck! If you do a reinstall, so be it. Troubleshooting has its limits... – Tom Wijsman Aug 17 '10 at 17:50
up vote 1 down vote accepted

For those who may experience the same issue, this seems like it is a possible solution based on my own experience and through helping others. First, while the coincidence is amazing, these problems are unrelated. I will mark this as the correct solution unless someone experiences the issue and cannot use the below methods to fix the problem.

Steam will need to be uninstalled and reinstalled. This will sometimes happen with steam when it is doing an update and doesn't patch itself correctly. You should move your steamapps folder (located in C:\Program Files (x86)\Steam) somewhere else during the uninstall/reinstall so that you don't have to download all of your games again. After installing, rename the new folder steamapps-backup and copy your old steamapps folder back in.

StarCraft II will need to be repaired. This will sometimes happen when your game requires an update, but the updater doesn't bother checking for it. Without the update, you can't connect to Unfortunately, there isn't a way that I know of to just kick-start the updater. Go to Start> All Programs > StarCraft II> "StarCraft II - Repair"

I think this happened to me because there was both a Steam update and a StarCraft II update at the same time. I was running StarCraft II in Steam so I could utilize the Steam overlay, even though StarCraft II is not a Steam game. Possibly because both things tried to update simultaneously, they screwed each other up.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .