Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two macbooks in my home one is connected to internet via an Ethernet cable and I want the second one to connect to internet through the first using wireless...is that even possible?Any help would be appreciated...

share|improve this question
1  
What you are looking for is called bridging. –  Nifle Aug 17 '10 at 17:26

1 Answer 1

up vote 8 down vote accepted

Mac OS X includes a neglected feature called Internet Sharing in the Sharing Preference Pane to do just what you'd like to do.

You can turn this on by going to the Sharing Preference Pane in System Preferences, saying what connection you want to share and to what other device and check off "Internet Sharing". For wireless you can put a WEP (hence my saying neglected before) password on the wireless network. If you're having issues connecting to the internet with the second computer, make sure you have an IP address that doesn't start with 169.254.x.x and the first Mac's firewall will permit connections. I wouldn't recommend this as a long term solution however.

Screenshots to help out:

Preference Pane: Sharing Preference Pane

Airport Options: Airport Options


If for some reason DHCP is not working correctly (I found it quite flakey with 10.5 but works fine with 10.6) you can force it to work. At this point I find it's definitely going past the point where the effort expended would most likely be put into better use getting a router or something similar to fix the problem in a more scalable manner.

The screenshots are from Mac OS X 10.6 so the GUI will look slightly different for the different versions of Mac OS X but you want to enter the same numbers into the IP Address, Subnet Mask, Gateway and DNS fields.

  1. On the computer sharing the connection, give yourself an IP to be reached at.

    You can change this IP to any other private IP if you're familiar with how networks work. 192.168.10.1

  2. On the computer that is connecting, you give yourself another IP.

    Notice this one uses 192.168.10.2 instead. 192.168.10.2

  3. It's important to set the DNS on the second computer as the first computer isn't passing any information on to the second computer as to how the network "looks".

    I'm using Google's DNS Servers here for simplicity's sake but you could put any DNS Server's IPs here. DNS

  4. Make sure you can see the other computer using Ping (use Network Utility or ping on the command line) and then see if you can access the internet as well to make sure that the first computer is passing packets correctly. (natd is actually running on the computer sharing the connection)

share|improve this answer
    
I think the neglect has not been entirely accidental - you used to (10.4 is where I remember it) have the option of WPA encryption and a few other settings. +1 for an excellent and detailed answer, though. –  Scott Aug 17 '10 at 19:47
    
Thanks for the answer...I actually made it and I was able to see the network with my second computer, but I my IP starts with 169.254.xx so I wasn't able to connect, can you suggest a good way to change it? –  rabidmachine9 Aug 18 '10 at 16:00
    
If the IP is 169.254.x.x then for some reason the second computer is not getting it's information from the other computer - this could be due to a bug or a configuration issue. Try turning the Internet Sharing off and back on to start. If that fails, you'll have to manually set the IPs for both computers in the same subnet and using the first one as the Gateway. I can add it to the answer if necessary. –  Chealion Aug 18 '10 at 16:11
    
Please do...I will mark your answer as correct anyway, but it would be really nice if you do! –  rabidmachine9 Aug 18 '10 at 18:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.