Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a flat file with lines of data. When I pipe it through /bin/mail to myself, however, the text in my MS Outlook mail box will have certain lines next to each other (EOL lost). For example, the file has

... 
20100115  0.48856  0.53141  0.36264  0.36237
20100119  0.48047  0.53160  0.36643  0.36516 
20100120  0.48551  0.53396  0.36970  0.36690
20100121  0.53207  0.55707  0.38302  0.37606
....

and if I run cat data.txt | mail my.name@myfirm.com, I see

... 
20100115  0.48856  0.53141  0.36264  0.36237
20100119  0.48047  0.53160  0.36643  0.36516 20100120  0.48551  0.53396  0.36970  0.36690
20100121  0.53207  0.55707  0.38302  0.37606
....

Regardless of if I convert the flat file to unix or dos format, this happens. And it always happens to certain lines but not others. And after some experiment, turns out that if the first word of the next line ends with 0, then this always happens.

Why would that be? Any solution to the problem would be much appreciated.

share|improve this question

migrated from stackoverflow.com Aug 17 '10 at 17:24

This question came from our site for professional and enthusiast programmers.

    
While this problem could be solved programmatically, I doubt that your mail implementation lacks functionality that allows sending mail to Windows clients. Since "Any" solution would be appreciated, perhaps, you would instead try asking at superuser.com? –  Pavel Shved Aug 17 '10 at 16:45
    
Outlook likes to "prettify" things. I'd use the "check source" (or "see original") functionality in Outlook to see if it's really lost or if it's just displaying it that way. I'd guess the latter. –  Kaleb Pederson Aug 17 '10 at 16:55
    
Thanks for migrating my question here. I attempted to see Outlook source code following the instrux on this page, but I am still not able to see the source. The "Internet headers" field in "Message Optons" ends "Return-path" value, not the body of the email. Do you know why that might be the case and how do I see the source? I'm running Outlook 2003 SP3 under a 64x Windows XP, with Symantec Enterprise Vault behind our corporate firewall. –  Zhang18 Aug 20 '10 at 13:00

1 Answer 1

From this knowledge base article, the steps to Disable the feature that removes extra line breaks in Outlook 2003 are:

  1. Open Outlook.
  2. On the Tools menu, click Options.
  3. On the Preferences tab, click the E-mail Options button.
  4. Click to clear the Remove extra line breaks in plain text messages check box.
  5. Click OK two times.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.