Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My T60 IBM keeps the start menu on disk instead of in memory after I open a number of programs and don't use the start button for some time.

So When I try to access, perhaps, "Connections", it takes time for the machine to respond. One problem that exacerbates this is that the "All Programs" link is directly above the "Start" button when the window opens. As I move the cursor, it generally moves over the "All programs" switch and locks there until the computer gets the info back into memory.

So, once it is in memory, I then have to move the cursor OUT of the "All Programs" area and then move it to the section I actually want.

I find this extremely annoying.

Can anyone help?

Other suggestions besides mine are welcome.


EDIT: I just had a thought. Is this related to the fact that I have the task bar hidden when not in use?

EDIT: Okay, just got another idea. Can I stop the start menu from going to the swap file?

share|improve this question
Do you have any proof of this? Process Explorer (Page faults), Process Monitor... – Hello71 Aug 17 '10 at 23:39

Whenever you open an application, (or a menu, or a document) Windows has to load that object into memory. If you don't have enough available (unused) memory, it swaps whatever has been sitting in memory the longest without being used to your hard disk, freeing up some memory. That disk space is usually called the swap file. Since hard drives are mechanical, they are much slower than computer memory.

So, the more memory that your computer has, the more things you can open/start/launch/do before Windows has to start swapping out to that sloooooow hard drive. Your All Programs menu problem is a symptom of doing more stuff than your computer has memory to handle. Note that you could still see those symptoms with 4, 6 or even 8 Gig of RAM, depending on how much stuff you do.

Solution 1: add more memory

Solution 2: this won't fix your memory issue, but it will stop one menu (like the All Programs menu) from getting in the way of other menus. The problem is that Windows has a "delay" of .4 seconds from the time the mouse pointer hovers over a menu to the time it starts to expand that menu. By making that delay really long, menus only open when you click on them.

To fix this, you must edit the Windows Registry. You can literally break Windows if you delete or change the wrong setting in the Registry, so proceed with caution. Click Start, (in XP click Run next), type regedit, press Enter, navigate to HKEY_CURRENT_USER \Control Panel\Desktop. Look for an entry called MenuShowDelay. If it's not there, right-click an empty spot in the window and select New\String Value. Type MenuShowDelay and press Enter. Now double-click MenuShowDelay, and give it a value of 65000. The start menu, taskbar, and menus will now stop auto-appearing, and must be clicked on to open.

share|improve this answer
Thank you for your response. I have the maximum memory allowed 32bit. If I happen to scroll over a "menu" item (e.g. All Programs), the computer freezes while the it loads the menu into memory. Then I have to move the mouse to collapse the menu and then move to the item I want. The placement of the "All Programs" link, just above the "Start" button makes it very likely that I will invoke that item on my way to the item I am actually interested in, causing me frustration. Therefore, I was hoping there was some way to order the Start Menu so as to reduce my frustration. Regards, – Xavierjazz Aug 21 '10 at 21:56
As to solution 2, the delay happens after I click on the start menu and want to access, for example, the add/remove program. Thanks again. Regards, – Xavierjazz Aug 21 '10 at 21:57

Well the best way is trial and error, unhide your taskbar and see if the problem persists, if not then it's because of that, also check your paging file, you can try not having one at all, if you have sufficient ram that is, and see if the start menu loads faster when there's not cache on the disk.

Hope it's understandable.

share|improve this answer
Thanks. Where would I find my paging file? – Xavierjazz Aug 17 '10 at 23:47
Right Click Computer > Properties. On the left sidebar you will see Advanced System settings > Advanced Tab > Performance -- Settings Button > Advanced Tab > Change.. You will be able to see your paging file properties here. – Sandeep Bansal Aug 19 '10 at 22:45
Thanks, but "Computer>Properties" is not enough information. If I click on "My Computer>Properties" or "Disk C>Properties" I get no sidebar similar to the one you describe. ???????? – Xavierjazz Aug 21 '10 at 22:01
Type in the start menu "advanced system settings" without quotes, and there should be a link to where you can get to it. – Sandeep Bansal Aug 22 '10 at 19:44
What/where is the "Start Menu"? There is no such thing when I click on the Start button. – Xavierjazz Aug 23 '10 at 15:32
up vote 0 down vote accepted

As far as I can find out the answer to my question is "No". Any other advice?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .