Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to make the Mac OS X guest OS adapt the resolution of the host OS given that there's no guest additions yet as of the moment?

share|improve this question

That should help solving your problem.

  • open this link
  • go down to Step 7: Make the Screen Bigger

Note: Install Multibeast 4.6.1 first (registration required)

share|improve this answer

There is no way for it to automatically adjust, but you can specify a custom resolution for the guest to use.

You can manually edit the VirtualBox configuration, and the boot file in OS X to use a custom resolution. It's a two part (Host VM/Guest) process to enable the resolution.

Here are the steps:

  1. First, make sure VirtualBox is not running. Close it if it is.

  2. Add the following setting to the <ExtraData> section of your VM's XML file:

    <ExtraDataItem name="CustomVideoMode1" value="1680x1050x32"/>

    You can change the value above to your preferred display resolution, e.g. 1280x1024x32.

  3. Save the file and start your VM.

  4. In Mac open the /Extra folder in the Finder.

  5. Drag the file to the desktop.

  6. Open the file on the desktop in the editor.

  7. Locate the <key>Graphics Mode</key> entry, following that there should be a <string>xxxxxx</string> entry. Edit this entry to match the Custom Video entry from step 2 above. i.e. <string>1680x1050x32</string>

  8. Restart your VM and the new display resolution should be effective.

Good Luck!

share|improve this answer
This doesn't work. The only thing that seems to make a difference is using the solution described here:… – user41270 Jun 14 '11 at 7:42
This definitely doesn't work, the copy on the desktop is just ignored. See… for a more up-to-date method. – Sam Salisbury Mar 11 '13 at 15:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.