Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a hard time trying to get a XP laptop online. Whether I use either wifi or ethernet I get the same result. It tries to get an ip but times out and just stays connected with limited funtionality

The network is fine. It has several computers connected to it fine. I've checked the router to see if maybe its filtering its MAC address(s) but no. I've checked for static IP settings in the adapter TCP\IP settings but it's all on DHCP. Have removed all anti virus\firewall software, even used removal tools such as the Norton Removal Tool. Reinstalled drivers, updated drivers. Run winsock fix Checked services (DHCP, DNS, etc)

Running out of ideas now :(

share|improve this question
Have you tried giving it a static IP in your network and ping it? – Andrew J. Brehm Aug 18 '10 at 13:31
Thanks for the suggestion, doesn't work though. Definitely setting that up right because I have some computers on the network with static addresses – Michael Aug 18 '10 at 16:11
The router is also the DHCP server? What is the range of IP's available to the DHCP server? Can you reboot the DHCP server and try again? Also, do you have a bridge defined in the XP configuration? – dbasnett Aug 19 '10 at 18:12
You might consider trying out this laptop on another network for debugging. Have you checked that the DHCP Client service is running properly (can be checked in services.msc)? – Matthieu Cartier Jan 26 '11 at 12:02

You didn't mention having tried this, so here goes: from the command line, enter these commands:

ipconfig /release
ipconfig /renew

share|improve this answer
Sorry yes that is one I tried but no luck with that, thanks :) – Michael Aug 18 '10 at 16:09

At this point, I would burn and boot up a linux live cd (Ubuntu's is nice), and try to connect over the wired connection. If this works, then there is something screwy with the OS. If not, you've ruled out any software issue on that machine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .