Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to get an Orange UK 3G dongle to work with Slackware 13.1 (ships with what is allegedly pppd v2.4.5). It seems to successfully authenticate with CHAP (not that the ISP seems to really care), but then falls down in what I think is IP setup. I am using the command:

pppd connect 'chat -v -f /root/connect.cmds' nodetach debug user any password any noccp  /dev/gsmmodem

With the following connect.cmds:

'' AT+CGDCONT=1,"IP"
OK ATDT*99#

And get the following output:

Script chat -v -f /root/connect.cmds finished (pid 2212), status = 0x0
Serial connection established.
using channel 79
Using interface ppp0
Connect: ppp0 <--> /dev/gsmmodem
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2b6e90d5> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x2d <asyncmap 0x0> <auth chap MD5> <magic 0x10fe7ad> <pcomp> <accomp>]
sent [LCP ConfAck id=0x2d <asyncmap 0x0> <auth chap MD5> <magic 0x10fe7ad><pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x2b6e90d5> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x2b6e90d5]
rcvd [LCP DiscReq id=0x2e magic=0x10fe7ad]
rcvd [CHAP Challenge id=0x1 <36a6c6907a6dcae164d8d9b0f0e70dae>, name ="UMTS_CHAP_SRVR"]
sent [CHAP Response id=0x1 <eeac223f515ff3e1f2d97cdc5ce4bfad>, name = "any"]
rcvd [LCP EchoRep id=0x0 magic=0x10fe7ad 2b 6e 90 d5]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0>]
rcvd [IPCP ConfNak id=0x1 <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns10.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [IPCP ConfNak id=0x2 <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns10.0.0.0> <ms-dns2 0.0.0.0>]
Modem hangup
Connection terminated.

Any ideas? Using the novjccomp and/or novj did not help. It is not a dongle problem as it connects fine from windoze7, and I doubt it is a pppd problem as other dongles on different providers connect ok.

share|improve this question
add comment

1 Answer 1

Solved. Orange (unlike Vodafone/3) dislikes the APN being left empty. Hence:

'' AT+CGDCONT=1,"IP","consumerbroadband"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.