Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am facing problem with my Windows network adapter. It detects all the available networks but it shows "Limited Access" for the network I wish to connect. On diagnostics it gives "The wireless network adapter is experiencing problems" and on further diagnostics it says "There might be a problem with the driver for the Wireless Connection Adapter". What to do?

share|improve this question
I have Intel Pro network adapter – Akhil Aug 18 '10 at 19:57
I think this is windows guessing the problem so I wouldn't guarantee that is the problem. I get this on my laptop but its when I connect to public Wi-Fi without logging into to their system or if I am connecting to my own home network a restart solves it. – CodeBlend Apr 13 '12 at 13:40
It detects all the available networks but it shows "Limited Access" for the network I wish to connect, means its not getting connected to any of the wireless network or simply the one you are trying to get connected. did you tried it with any other network? are you getting limited access error even when you connect to any of the network? what about the router setup, are you using DHCP? check whether network adapter is configured with any static IP? – Renju Chandran chingath Jul 17 '13 at 6:47

The problem happens to me all the time. I think it is one of the reasons to prefer linux over windows since these problems only accure in windows.
You want it or not you have and will have these kind of problems in the future. Thats the downside of windows.

This is what I do every time this happens to me:
Go to Control Panel -> Network and Internet -> Network and Sharing Center -> Change adapter settings
You see one or more wireless adapters, disable the first one which is named your real wifi card (ie intel) By right clicking on it and selecting Disable:
enter image description here
Then after some seconds, again right click and select Enable.
The problem should have gone now.

share|improve this answer

Firstly, have you been able to connect to any network? If so, your drivers are probably fine.

If not, you can try the following -

I don't have Windows 7 in front of me, but the process should be similar:

  1. Go to the Computer Management console
  2. Select Device Manager
  3. Find the Wi-Fi adapter
  4. Right click and select Uninstall
  5. Find the command Scan for Hardware changes, this might be in a menu or if you right click it might be in the box that appears
share|improve this answer
Right click on any device and select "scan for hardware changes" – Moab Apr 10 '11 at 19:50

I don't think this is a driver problem, looks more like IP misconfiguration to me (that's what "limited connectivity" isses in Windows are 90 percent of the time). Here's what I'd do:

Fire up a console (Run, enter 'cmd') and enter 'ipconfig'. It should report information on various network connections - find the one associated with your WiFi adapter. What does it say for "IPv4 address"? You might want to paste all it reports for your WiFi adapter in here.

(And now I see how old that post is. Sigh.)

share|improve this answer

it might be the issue caused due to DHCP is not enabled. once its enabled it will receive the IP from the router that is not assigned to other computer.

share|improve this answer

The case you are experience in which Wi-Fi connection is displayed as limited is due to the ip conflict.To troubleshoot the case

(i) Right click on the Wi-Fi icon displayed on the task bar and chose Troubleshoot Problems.

(ii) Now an Windows would Pop-up and it would check the internet connection.

(iii) If it show as it is able to connect then choose the txt "I am having different problems".

(iv)Then chose to connect another connection.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .