Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever a website changes, finishes loading or re-loads; Google Chrome moves me to that Space. It drives me crazy. Is there any way of stopping that?

share|improve this question
1  
Stop Spaces from switching spaces due to an app coming to the foreground: defaults write com.apple.Dock workspaces-auto-swoosh -bool NO && killall Dock –  user65756 Feb 2 '11 at 11:14
add comment

3 Answers

up vote 4 down vote accepted

I've submitted this as a bug to Chrome, so far nobody denied that this is a problem, but nobody confirmed it either: http://code.google.com/p/chromium/issues/detail?id=46137

share|improve this answer
    
Please help this bug get fixed faster by voting for it. Go to the bug page and click the star near the upper-left of the page. –  Leopd Mar 14 '11 at 22:58
add comment

To prevent OS X from ever automatically to switching spaces with open windows, you can enter the following into a Terminal window.

defaults write com.apple.dock workspaces-auto-swoosh -bool NO && killall Dock

You'll still have to open a new window for the application though: Click the application in the dock, then press cmd+n.

share|improve this answer
add comment

I don't think so. You could set Chrome to run in every space; that's what I do with my browser.

share|improve this answer
1  
What do you mean by running in every space? I get all the same chrome windows replicated in all the spaces? –  Pablo Aug 20 '10 at 4:36
1  
System Preferences -> Spaces lets you assign applications to specific spaces. If you select "every space" instead of a specific one, the windows of that application will follow you around as you move from space to space. It sounds like Chrome is stealing focus, which might still be disruptive if it's popping up from the background when you're in a different app, but I don't recall that behavior the last time I used Chrome. Make sure you're updated, and file a bug report if it persists! –  NReilingh Aug 20 '10 at 15:32
    
Google Chrome doesn't show up at all in Spaces preferences on my OS X 10.6.5. There are a couple of "Unknown application" there I've tried to alter the space for, but to no avail. Chrome still only displays on the space that was active when it was first opened. –  asbjornu Dec 16 '10 at 20:06
    
Did you click the plus button and add it to the list? I can do this and it works the way I described. –  NReilingh Dec 17 '10 at 1:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.