Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The mousepad or touchpad in Dell Inspiron 1545 drive me crazy. It moved to other places unexpectedly. I took me more time to retype password or rewrite my programs, my documents.

I'm using Ubuntu 10.04. Tried install gpointing-device-settings but it was not work. It did not recognize the touchpad.

share|improve this question
1  
Is there a Fn key to turn off the touch pad? –  MrStatic Aug 20 '10 at 4:28
    
No Fn key to turn off the touch pad. –  TopViet Aug 22 '10 at 16:13

4 Answers 4

Try synclient TouchpadOff=1

I wrote an ON/OFF script some time ago, more details here.

share|improve this answer
    
It did not work on my Dell INSPIRON 1545 and Ubuntu 10.04. The Touchpad is running but when you execute xinput list or synclient -l, you don't see any Touchpad device. I got this message: "Couldn't find synaptics properties. No synaptics driver loaded?" when execute synclient TouchpadOff=1 or synclient -l If I go to System -> References -> Mouse, no tab for Touchpad. –  TopViet Aug 22 '10 at 16:10
    
Probably you have an Alps touchpad ... sorry, I don't know how to configure that one. –  Patkos Csaba Aug 22 '10 at 17:49

From this thread, based on this article :

First edit your xorg configuration file:

  1. Alt+F2
  2. Type gksu gedit /etc/X11/xorg.conf
  3. Find the line that says Section InputDevice
  4. Under that section add a line that reads: Option "SHMConfig" "on"
  5. Save and close that file

Now to turn it off:

  1. Alt+F2
  2. Type "synclient touchpadoff=1"
  3. Hit enter and you're done

To turn it back on:

  1. Alt+F2
  2. Type "synclient touchpadoff=0"
  3. Hit enter and you're done
share|improve this answer

I finally found a solution to the infamous problem of not being able to disable the Inspiron's touch pad after I upgraded from Vista to Win7 32bit.

I had to install an older touchpad driver to make this work. The driver is Dell R165804, this driver is labeled "Dell Touchpad Driver for XP/2K and Vista 32" when I installed it in my Inspiron 1545 it added the Dell Touchpad tab to my mouse settings under the control panel. Then I opened the control panel, clicked "mouse", under the Touch Pad tab click on the picture of the touch pad. I was then able to click "Device Select" and check the box that says "Disable Touchpad when external USB device is present".

Now when the USB mouse is attached the touchpad is disabled and I don't have my cursor jumping around while typing due to my fat thumbs touching the mouse pad.

Hope this helps someone else out there!

share|improve this answer
1  
We are talking about Ubuntu here, nothing to do with Windows drivers. –  Bruno Pereira Jul 28 '12 at 18:29

Many answers tell you to go to the control panel, find the mouse and pointers window, and turn off the touch pad. Problem is, there is no "touch pad" icon. Same for going to the task bar and clicking on the touch pad icon. Not there either. Here is how you fix it.

On the internet, go to "Dell Drivers" Enter your service tag code (look on the bottom of your computer for the service tag and or serial number. Once you do that, you will be directed to the available drivers for the 1545. Select "Input" and three drivers will come up. Select ALPS DRIVER R270497.exe and download it. Once downloaded, run Setup and install the driver. You will have to restart to activate after installing. Then look at the task bar. A new icon will be there, called "Touch Pad". Right click on that and you will find a box to check that says: "Disable touch pad when external mouse is detected. Now you are in business without that damn touch pad jerking your pointer all over the place when you type.

share|improve this answer
1  
We are talking about Linux here, nothing to do with Windows drivers. –  Bruno Pereira Jul 28 '12 at 18:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.