Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an older Dell Precision 530 running CentOS 5.5. I am seeing these errors in logwatch:

-------------------- Smartd Begin ------------------------

Currently unreadable (pending) sectors detected: /dev/hdb - 48 Time(s) 1 unreadable sectors detected

Offline uncorrectable sectors detected: /dev/hdb - 48 Time(s) 1 offline uncorrectable sectors detected

So I replaced hdb with a different drive I had lying around, and I still get the same errors. I think it's highly unlikely that I'd get the same exact errors on two different drives, so I'm wondering what else could cause this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It is possible that both drives have failed. On the other hand, it could be that the hard drives do not properly support S.M.A.R.T. and so are giving erroneous results.

I would try badblocks (which manually reads and writes from/to each hard drive sector) to see if the drives are actually bad.

share|improve this answer
    
I tried running badblocks on the drive while it was unmounted, but it kept complaining that it couldn't do it because something was using it. The drive is also using LVM, if that matters. I thought umounting it was enough. –  churnd Aug 22 '10 at 3:06
    
I needed to run it on /dev/mapper/storage, not /dev/hdb. It ran but I still get the message. –  churnd Aug 26 '10 at 16:02
    
You could try either running a read-only badblocks test, or removing the drive from your LVM group. –  Martey Aug 26 '10 at 21:41
    
I just went ahead & replaced the drive. –  churnd Sep 27 '10 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.