Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having this problem for several weeks now: from time to time my computer freezes, the desktop loses all the icons and the HD light goes on. Most of the time this gets solved by waiting 2-5 minutes, but sometimes there's no other choice than rebooting

By opening a new terminal, I get the following message (more or less, since I don't have my laptop with me right now):

ata1.00: status: { DRDY ERR }, exception Emask 0×0 SAct 0×0 SErr 0×0 action 0×0

OR

failed (errno=-16)

(the latter usually meaning that I have to reboot the computer)

The funny thing is that when I'm on a terminal none of this happens (I can listen to music, compile applications, browse the Internet, etc)

So, my question is: can this be happening because of GNOME or more likely it's a HD failure?

BTW, I'm running Ubuntu (¡please don't punch me!) 9.10 .

share|improve this question
    
You'll get better responses on SuperUser. –  Peter Tillemans Aug 20 '10 at 18:16
1  
I didn't know about SuperUser, just StackOverflow and Serverfault, ¡thanks for migrating the question to this site! –  Gastón Aug 20 '10 at 20:52
add comment

migrated from stackoverflow.com Aug 20 '10 at 18:16

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 1 down vote accepted

It's hard to say but to me it sounds like a hardware problem. Can you reliably reproduce this? Is there a list of steps that always cause this? If no to both of these, then I would be very certain it's a hardware failure.

share|improve this answer
    
This usually happens when it has to display several folders+archives with Nautilus. That's the only one I can reproduce that whilst is not 100% sure going to trigger the issue, it does most of the time. I too, thought it was a hardware problem, though I had the wishful thinking it would be something with the GUI (because if it is the HD, I'll have to backup all the 500GiB which is a pain in the ass) –  Gastón Aug 20 '10 at 18:57
    
@Gastón: Hmm well that's a little more consistent, but sometimes a minor hardware issue can be agravated by certain software. Have you tried testing for problems on the harddrive? You could also try mirroring to a new hard drive and see if booting from the new drive gives problems in the same situation. –  FrustratedWithFormsDesigner Aug 23 '10 at 15:00
    
The only thing I've tried is doing fsck, which found the first time some corrupted nodes and nothing later. I will buy a HD next week (backup my stuff there) and run a couple of tests. –  Gastón Aug 25 '10 at 18:39
add comment

Looks like a hard drive problem to me. Maybe GNOME is triggering it because it uses stuff on the bad part of the drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.