Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have created multiple profiles for my Firefox... then i have created different shortcuts for each profile by setting Target to this

"D:\Program Files\Mozilla Firefox\firefox.exe" -p "myProfile1"
.
.
.
"D:\Program Files\Mozilla Firefox\firefox.exe" -p "myProfileN"
"D:\Program Files\Mozilla Firefox\firefox.exe" -p "Guest"

now when i start default firefox that is (installdrive&dir)\Mozilla Firefox\firefox.exe

it starts "D:\Program Files\Mozilla Firefox\firefox.exe" -p "myProfile1"

why isn't it running a non profiled instance but myProfile1... and if not then how to make it run some other instance automatically not by adding arguments to the target...

Why myProfile1 has become the default profile

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The answer lies within the profiles.ini file in your local Firefox data directory within your user profile. Depending on your version of Windows (and localized version), you should find it one of the following directories, where usr is your local user name.

Windows Vista & 7:

C:\Users\usr\AppData\Roaming\Mozilla\Firefox

Windows XP:

C:\Documents and Settings\usr\Application Data\Mozilla\Firefox

In the profiles.ini file there is an option in the [General] section named StartWithLastProfile, which apparently defaults to 1, meaning it will always start the browser with the last used profile. If you want to change this behavior simply set it to 0.

Note: See also Profile folder and Profiles.ini file

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.