Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I occasionally use programs originally designed to run in Japan using Microsoft AppLocale. When loading a program this way, AppLocale specifies that it's only designed to be a temporary solution and that you're supposed to specify a language for Windows to use when running non-Unicode programs.

I tried doing that a couple years back, but ran into some problems; I didn't remember the details. Last night, I decided to try again.

I opened the Control Panel, went to Language & Regional Settings, and followed the rest of the Help file's instructions. Ordinarily it would ask me to insert my copy of Windows XP in order to copy over Japanese regional settings, but apparently the files were still on my computer from the last time I'd tried, so it let me use those instead... which was fortunate, as I can't remember what I've done with my XP install discs. I let the system configure my settings for about 20 minutes, and then it asked me to reboot.

Now my computer immediately reboots any time it would open the desktop. I've tried loading into Safe Mode, loading with the last known correct settings, fiddling with my BIOS settings (although I'm leery of doing too much since I don't know exactly what will wind up burning out my motherboard)... At this point, the only thing I can think of is to use a windows boot disk to try to correct the settings, but having ransacked my apartment, my parents' house, and the house of the guys I used to live with, I can't find it anywhere. Is this something I can fix without spending money and without having those discs, or am I doomed to either buy another copy of XP/take my computer to a repair center?

In response to Redha's answer: I get the following error whether starting normally or in some flavor of Safe Mode (including w/ command prompt). "Stop: c000021a {Fatal System Error} The Windows Logon Process system process terminated unexpectedly with a status of 0xc000001d (0x00000000 0x00000000). The system has been shut down." I googled that, and it does seem to be an issue mainly Japanese users encounter; however, most of the discussion seemed to revolve around running software on the desktop, like Housecall and Hijack This. Since I can't reach the command prompt, I'm not sure if there's a way to try the last things.

Update 09/18/2010: Despite buying a new hard drive and a new operating system, I haven't given up on salvaging the old one, because I really don't want to spend days tracking down a bunch of drivers for my network card and other hardware, reinstalling all my software, etc. Searching for the error again, I came across the following page:

http://www.seasonsecurity.com/how-to-fix-stop-c000021a-fatal-system-error-error-in-windows-xp-without-any-cd-roms-64007

I tried a number of proposed solutions, including response #59 from Pierre, as follows:

Hello all, and sorry for my poor english, i had the same problem with a client’s computer, here is the way i resolved that: client computer has Win xp pro with sp2, it wasn’t bootable even in safe mode. So i booted with a bartPE cd, and renamed the following files:
csrss.exe –> csrss.exeold
win32k.sys –> win32k.sysold
winlogon.exe –> winlogon.exeold
I took these files from a working computer runing Windows XP Professional SP3 (I didn’t have a SP2 >computer with me) and put them back in the bad computer. That worked perfectly, no idea why… Hope it will help some people.

I got those three files off a computer successfully running Windows XP Professional SP3; replacing them on the afflicted drive reenabled the login process, and getting to Windows no longer presents BSOD. Instead, it gives me the old Windows Explorer has encountered a problem and needs to close. We are sorry for the inconvenience. and gives me the option to generate an error report. Clicking the button to see what the report contains, I get the following information:

Error signature
AppName: explorer.exe AppVer: 6.0.2900.2180 ModName: kernel32.dll
ModVer: 5.1.2600.3541 Offset: 00009a51

Clicking the link for technical information about the error report generates an enormous page full of content. It starts with:

Exception Information
Code: 0xc000001d Flags: 0x00000000
Record: 0x0000000000000000 Address: 0x000000007c809a51

...and continues onward. I'm able to generate this error consistently, and while Explorer won't load, I can at least get into the task manager to run the command prompt and other resources. Anybody know what I should do next?

Update 09/19/2010: As mentioned in my comment on the answer below, I'd successfully completed the first half of the registry repair process that Dennis had linked to. Now that Windows was sort of loading, I reversed the instructions, restoring the original versions of SYSTEM, SECURITY, SAM, SOFTWARE, and DEFAULT in the Windows\system32\config folder; this has reenabled all my existing software and registry info, so while explorer.exe is still crashing, I am now actually updating this issue from the afflicted computer. No desktop, but Chrome's my default browser, and it successfully opened when I tried to view report details from the crash alert. So: I may not have emerged from the labyrinth quite yet, but I see the light at the end of the tunnel. All my software works if I launch it from task manager, except explorer. I can't believe I'm this close to restoring my original functionality. Thanks again for all your help, guys, and if you have any ideas of how to correct this last little bit of brokenness, I'd really appreciate it.

share|improve this question
    
Can you tell us in more detail what you did in control panel? As far as I know, nothing in Language and Regional Setting should be capable of causing problems which you have. –  AndrejaKo Aug 21 '10 at 8:00
    
It's hard for me to say, now. I remember bringing up Language & Regional Settings, finding the tab that had stuff about non-unicode programs--there was a list of languages for which support had been installed, and it had English as the default, but it also showed that Japanese had been installed. I selected it and confirmed that I'd like to make that the language for non-Unicode programs, which prompted a restart; after everything closed and Windows started shutting down, a screen came up that was copying files (counting up from 1 to 89 of 89 files to copy). It hasn't stopped rebooting since. –  jsnlxndrlv Aug 21 '10 at 8:44
    
I think the original install of Japanese language support must have been incomplete or otherwise corrupt; I'm assuming that I ran into this same problem last time I tried to make this change, but since I'd had the install disc with me then, I must have been able to reset my configuration. –  jsnlxndrlv Aug 21 '10 at 9:04
    
Reinstall is your best option. Try to contact a Microsoft's partner for a media replacement. Check ( en.kioskea.net/forum/affich-56326-find-my-xp-key ) on how to extract the original key. –  Redha Aug 25 '10 at 7:01
    
I haven't given up on salvaging the old one well done! –  naxa Jan 9 '13 at 10:12
show 2 more comments

5 Answers

up vote 1 down vote accepted

I had much the same problem with a notebook handed to me to fix; auto-reboot was off, so the 0xc000001d error would appear each time the machine attempted to start (by way of a blue screen).

Initial attempts at a chkdsk failed (no CD drive, had to start it via USB). I made another attempt the next day, so I could Google the error message, but to my surprise it suddenly decided to do the job and repair whatever filesystem errors it was complaining about. Unfortunately this had no effect on the blue screens.

Following the information posted above, I replaced csrss.exe, win32k.sys and winlogon.exe from a machine running XP SP2. This got me to the login screen, but after entering the password, Explorer promptly crashed. Task Manager worked and I had Command Prompt access.

I checked regional settings, but the computer seemed to be set to defaults in that area - see http://support.microsoft.com/kb/192806 as to how to get into control panel areas with only a command prompt.

The solution from there was easy in my case: Open a prompt window, rename c:\windows\explorer.exe, then replace it with a copy from the SP2 rig. On renaming the original, Windows promptly started complaining about system files being missing, and prompted me to insert an SP3 disc to replace them; though it shut up after I put the copy from the other computer in place and rebooted.

I'm getting security warnings when trying to copy files at times, which probably has to do with the mismatched system file versions. Presumably all would be fine if I'd had access to an SP3 disc, though these are the sort of errors that go away just by clicking an "ok" button.

The proper way to go about things is probably with the System File Checker (SFC), though I dunno if that'll run from the recovery console. This tool does require access to a disc to work properly though.

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true

share|improve this answer
add comment

No, setting the language for non-unicode programs does not normally break Windows. I do that at work on a regular basis. I think your XP is broken for good.

share|improve this answer
add comment

i had the same problem; switching to a different locale causes a BugCheck (BSOD) on startup:

How to edit registry from Vista recovery tool?

The only way to fix it was to use a recovery tool to change a registry entry from

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages\xx-YY

and change it back to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages\en-US

The bugcheck makes sense when you realize Windows is telling you that it cannot find files it needs.


So to answer your question: Yes, setting language for non-Unicode programs breaks Windows.

share|improve this answer
add comment

I think the crash is just a coincidence. Your registry may be corrupt. Look here http://support.microsoft.com/kb/307545 in order to recover a previous copy of the registry.

share|improve this answer
    
While I was able to use the Recovery Console from a copy of Windows XP Home that I just purchased to follow Step 1 of the manual process, Step 2 cannot be completed because, again, I can't access the desktop in safe mode, even after replacing the Windows/system32/config files. –  jsnlxndrlv Sep 18 '10 at 3:28
    
Since I can (sort of) access the desktop now, I'm going to try this again. –  jsnlxndrlv Sep 18 '10 at 20:18
add comment

Do you manage to see the desktop before it reboots? Let's eliminate the problem being in Kernel or something:

Else, it could be a startup software that's incombatible with the current Japanese environment. Try:

  • Start windows in Safe mode with command prompt.
  • Run %windir%\pchealth\helpctr\binaries\msconfig.exe. Disable loading startup items then restart.
  • Optionally, use %windir%\system32\intl.cpl to open Regional Settings and revert back to your language.

good luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.