Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just upgraded my system from ubuntu 8.04.4 LTS to 10.04.1 LTS, and I am seeing freezes. Suddenly, the system hangs and then the only way to recover it back is by doing a restart.

Following are the contents of kern.log at that point of time:

Aug 19 23:13:21 ubuntu kernel: [ 2440.380012] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Aug 19 23:13:21 ubuntu kernel: [ 2440.380027] render error detected, EIR: 0x00000000
Aug 19 23:13:21 ubuntu kernel: [ 2440.380044] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 214801 at 214797)
Aug 19 23:13:24 ubuntu kernel: [ 2442.824019] [drm:i915_gem_idle] *ERROR* hardware wedged
Aug 19 23:13:31 ubuntu kernel: [ 2450.568583] [drm:i915_gem_entervt_ioctl] *ERROR* Reenabling wedged hardware, good luck
Aug 19 23:13:32 ubuntu kernel: [ 2450.880012] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Aug 19 23:13:32 ubuntu kernel: [ 2450.880023] render error detected, EIR: 0x00000000
Aug 19 23:13:32 ubuntu kernel: [ 2450.880045] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 214803 at 214797)
Aug 19 23:13:34 ubuntu kernel: [ 2453.112033] [drm:i915_gem_idle] *ERROR* hardware wedged
Aug 19 23:13:35 ubuntu kernel: [ 2454.217610] [drm:i915_gem_entervt_ioctl] *ERROR* Reenabling wedged hardware, good luck
Aug 19 23:13:35 ubuntu kernel: [ 2454.532015] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Aug 19 23:13:35 ubuntu kernel: [ 2454.532025] render error detected, EIR: 0x00000000
Aug 19 23:13:35 ubuntu kernel: [ 2454.532052] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 214805 at 214797)
Aug 19 23:13:37 ubuntu kernel: [ 2456.588020] [drm:i915_gem_idle] *ERROR* hardware wedged
Aug 19 23:13:38 ubuntu kernel: [ 2457.764415] [drm:i915_gem_entervt_ioctl] *ERROR* Reenabling wedged hardware, good luck
Aug 19 23:13:39 ubuntu kernel: [ 2458.080013] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Aug 19 23:13:39 ubuntu kernel: [ 2458.080025] render error detected, EIR: 0x00000000
Aug 19 23:13:39 ubuntu kernel: [ 2458.080048] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 214807 at 214797)

System Details:

00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
01:00.0 Ethernet controller: Hangzhou Silan Microelectronics Co., Ltd. SC92031 PCI Fast Ethernet Adapter (rev 01)
01:02.0 Modem: PCTel Inc HSP56 MicroModem (rev 04)
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (LOM) Ethernet Controller (rev 81)
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

it seems that you too are affected by the inthell driver bug

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/541511

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/541492

here a bit background info

http://www.phoronix.com/scan.php?page=news_item&px=ODQ4NQ

share|improve this answer
    
Ah.. thanks.. any idea when we are expecting this to be fixed? –  peakit Aug 22 '10 at 13:22
    
@jai-ho umm... about six months ago? it has already taken way to long for ubuntu to fix this bug. just follow the bugs above and you will get notified. –  lesmana Aug 22 '10 at 16:22
    
And idea on how to switch back to Ubuntu 8.04... –  peakit Aug 22 '10 at 16:38
    
@jai-ho i think you will have to backup all your data and do a clean install. as far as i know there is no way to "downgrade". –  lesmana Aug 22 '10 at 22:05
    
Explored more.. Pybackpack is a nice tool to backup all your data. Details in ubuntugeek.com/… –  peakit Aug 28 '10 at 11:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.