Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu 10.04 on my HP Pavilion dv6000

After I installed it, the text in the console (when I press ALT+F1) was small and the console had a good resolution (I think the same as my LCD, 1280x800). Also, at boot, the "Ubuntu" logo was small and centered in the middle of the screen. That was good.

After that, I installed the nVidia driver via the "System->Administration->Hardware drivers" screen. After the driver was installed, the text in the console was larger and more pixelated, and also the "Ubuntu" logo was much larger and looked uglier because it was pixelated.

Can anyone help me change the resolution in the console and boot screen back to what it was before I installed the nVidia driver?

share|improve this question
    
Could this be duplicate of superuser.com/questions/66428/… ? It seems to me that accepted answer has settings for GRUB2 which is used in 10.04 –  AndrejaKo Aug 21 '10 at 8:03
    
I can't use "vga=". It says that vga is a legacy command and I should use "gfxpayload" –  Ove Aug 21 '10 at 8:35
add comment

2 Answers

Follow THIS, it works:

In Grub2 the vga= parameter is deprecated 1.

as root edit /etc/default/grub uncomment the GRUB_GFXMODE=640x480
and change the resolution to something you can use e.g. 1024x768

edit /etc/grub.d/00_header search for: set gfxmode=${GRUB_GFXMODE}
on the next line insert: set gfxpayload=keep verify that the new line
is before insmod gfxterm

run update-grub
run reboot to confirm that your changes worked!
share|improve this answer
add comment

use an editor (like vim or nano) and edit your /boot/grub/menu.lst (you'll ned root privileges). there you will find this:

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+

which gives you the resolutions for console to be loaded on startup... after you've decided which one is right for you, you should add one more parameter (also in your grub) to the following line:

kernel /vmlinuz26 root=/dev/sda1 ro vga=775

(it's the VGA part... just enter the right number)





edit: ok, nevermind the upper part, it's for grub1... here's what you should do for grub2: http://wiki.archlinux.org/index.php/Grub2#Setting_the_framebuffer_resolution in grub.cfg edit the following:

GRUB_GFXMODE=1280x800x32
GRUB_GFXPAYLOAD_LINUX=keep
share|improve this answer
    
Ubuntu 10.04 uses grub.cfg –  AndrejaKo Aug 21 '10 at 8:13
    
oh sorry, didn't know that... –  pootzko Aug 21 '10 at 8:18
    
What's the code for 1280x800 ? –  Ove Aug 21 '10 at 8:27
    
    
I can't use "vga=". It says that vga is a legacy command and I should use "gfxpayload" –  Ove Aug 21 '10 at 8:35
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.